1

I install Zekr Qur'an study software from Ubuntu Software on Ubuntu 16.04.1 LTS

In order to run, I must install this

sudo apt-get install libwebkitgtk-1.0-0

after Zekr can run, I got diacritics (harakaat/tashkeel) not displaying properly.

zekr


I think, it can be fixed by change the font. Tools > Options > View

  • Setting View before I changed

    before changed

  • Setting View after I changed quran_fontName add KFGQPC Uthmanic Script HAFS

    after

    RESULT : Diacritics still not displaying properly

    after view


P.S.

I have installed this font KFGQPC Uthmanic Script HAFS, KFGQPC Uthman Taha Naskh, Scheherazade, mry_KacstQurn, me_quran and change quran_fontName with that font. but the result is same, diacritics not displaying properly.

any ideas ?

Thank You so much for help

  • Have you tried to make use of the standard fonts for Arabic in Ubuntu? sudo apt install fonts-arabeyes fonts-kacst – Gunnar Hjalmarsson Jan 26 '17 at 10:54
  • I have tried but not solve my problem. – ryanw Jan 26 '17 at 11:13
0
  • This should be reported as bug to Zekr project.

    As I had tried similar experiment before, I expect the developer is trying to make diacritics (harakaat/tashkeel) with different color than letters.

    So Zekr prints letters without diacritics on a layer, then diacritics on another layer.

    Which may work for some font/rendering-kit combinations but not for all. Diacritics are not in the correct position with respect each letter.

  • Try remove all fonts from that priority list of quran_fontName put only: Scheherazade or me_quran .

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.