2

I have been using Netflix on 2 computers for weeks, both with Ubuntu 16, one is a 32 bits computer and the other is a 64 bits. I made them work reading this post: Now that I have Firefox 49 or higher, how do I watch Netflix? and they worked fine but, two weeks ago the trick stopped working on the 32 bits machine (It's still working on my laptop, the 64 bit machine) and I can't understand why. It start to load the video and the message: https://help.netflix.com/es-es/node/23742 does not appear, instead of that, I get the error-code: M7363-1260 which can mean:

(I cant post more than 2 links but googling this error there are three or four branch of it that say maybe something is outdated on my browser (maybe widevine) But I've been trying to update it and I thing it is updated...

Somebody have this problem??

There are more alternatives that work appropriately? I've been trying to install google chrome with wine without exit and to made chromium able to reproduce netflix video with pipelight but same)

I would thanks all kind of help!

  • Welcome to Ask Ubuntu! Netflix should work fine on both Chrome and Chromium, and you dont need wine to install Chrome. Get Chrome 32bits from google's site , open the file (with Software Installer by default) and it should be installed without troubles. – M. Becerra Jan 25 '17 at 11:22
  • 1
    There is no Chrome 32 bit at the Google site. – Pilot6 Jan 25 '17 at 11:26
  • as Pilot6 said, the problem is that today there is no chrome 32 bits for linux (official) :/ – grg121 Jan 25 '17 at 17:55
  • Did you manage to fix it? – Promille Jan 27 '17 at 11:54
  • I haven't been able to fix it yet – grg121 Jan 28 '17 at 10:03
1

Netflix should work fine in Firefox if you're using one of their newer versions which supports CDM (a solution for playing DRM-media through HTML5). (Firefox introducing this made rather big fuzz actually - read here or here for more information and tips).

It hard to say why it's not working in your case. Widevine and Adobe Primetime should download automaticly by Firefox I think. You could start by verifying that both Google Widevine and Adobe Primetime is set to "Always Activate":

...

Then check that Firefox is set to play DRM content:

Enable DRM Firefox

Also delete all your cookies and set Firefox to remember history:

Remove all cookies under "remove individual cookies"

If this doesn't work try to re-install firefox (sudo apt-get install --reinstall firefox I guess).

Best of luck!

  • that did not work – grg121 Jan 28 '17 at 16:02
  • This does not work on my 32 bit system. – Organic Marble Feb 10 '17 at 1:32
-1

UPDATE: Netflix now supports Firefox on Linux as well. No user-agent spoofing needed.

As described in this comment on the bug report here, you may have to change your user agent to

Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.100 Safari/537.36

...and Netflix will work again.

I'm using User-Agent Switcher extension here. The original string mentioned Chrome/40, I think.

Remember it's not a bug in Firefox. It's just that Netflix doesn't officially support Firefox on Linux yet.

  • This did not work in my 32 bit system. – Organic Marble Feb 10 '17 at 1:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.