2

I have a USB SteelSeries 9H with their own soundcard. It used to work by default on 16.04, but after the upgrade they do not anymore.

When I plug them in and execute cat /proc/asound/cards I get

     0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xd3710000 irq 31
 1 [Headset        ]: USB-Audio - SteelSeries SC2 USB Headset
                      SteelSeries SteelSeries SC2 USB Headset at usb-0000:00:14.0-3, full speed

I uninstalled alsmixer and pulsaudio, I tried running alsmixer and set the headphones (they are visible there) to be used default, but I get

cannot load mixer controls: Invalid argument

Under the Sound option in Ubuntu, the headphones are not visible at all. Put if I plug any other headphones via jack (not USB) they work properly.

Nevertheless, if I plug them in with dmesg --follow running, I can see the system detects them. Log below

[ 1343.477597] usb 3-3: new full-speed USB device number 8 using xhci_hcd
[ 1343.621952] usb 3-3: New USB device found, idVendor=1038, idProduct=1216
[ 1343.621958] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1343.621960] usb 3-3: Product: SteelSeries SC2 USB Headset
[ 1343.621961] usb 3-3: Manufacturer: SteelSeries
[ 1343.621963] usb 3-3: SerialNumber: 000000000000
[ 1343.623863] usb 3-3: 2:1: cannot get freq at ep 0x1
[ 1343.624160] usb 3-3: 2:2: cannot get freq at ep 0x1
[ 1343.624453] usb 3-3: 2:3: cannot get freq at ep 0x1
[ 1343.627740] usb 3-3: 10:0: cannot get min/max values for control 3 (id 10)
[ 1343.628841] usb 3-3: 10:0: cannot get min/max values for control 4 (id 10)
[ 1343.629938] usb 3-3: 10:0: cannot get min/max values for control 5 (id 10)
[ 1343.630944] usb 3-3: 10:0: cannot get min/max values for control 8 (id 10)
[ 1343.631990] usb 3-3: 10:0: cannot get min/max values for control 9 (id 10)
[ 1343.636688] input: SteelSeries SteelSeries SC2 USB Headset as /devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3:1.3/0003:1038:1216.0008/input/input21
[ 1343.636850] hid-generic 0003:1038:1216.0008: input,hidraw2: USB HID v1.11 Device [SteelSeries SteelSeries SC2 USB Headset] on usb-0000:00:14.0-3/input3
[ 1343.662036] usb 3-3: 10:0: cannot get min/max values for control 3 (id 10)
[ 1343.663038] usb 3-3: 10:0: cannot get min/max values for control 3 (id 10)
[ 1343.664030] usb 3-3: 10:0: cannot get min/max values for control 3 (id 10)
[ 1343.665041] usb 3-3: 10:0: cannot get min/max values for control 3 (id 10)
[ 1343.667033] usb 3-3: 10:0: cannot get min/max values for control 4 (id 10)
[ 1343.668041] usb 3-3: 10:0: cannot get min/max values for control 4 (id 10)
[ 1343.709474] usb 3-3: 10:0: cannot get min/max values for control 3 (id 10)
[ 1343.719956] usb 3-3: 10:0: cannot get min/max values for control 3 (id 10)

Does anybody has any suggestions about what I can do to fix the problem?

1
  • Could you please edit your question to include the output of the terminal commands lspci -nnk | grep -A2 Audio, aplay -l, and pactl list short sinks? Please also make sure that the relevant audio channels in alsamixer (terminal) or gnome-alsamixer (GUI) have their volume turned up and aren’t muted. Thanks. Feb 2, 2017 at 1:39

1 Answer 1

1

After trying out aplay -L I concluded it is just a soft problem.

Someone recommended pavucontrol. With the help of this little tool I was able to fix the problem and re-enable my headphones.

1
  • thank you. pavucontrol worked for me currently.
    – Hari K T
    Aug 9, 2017 at 5:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .