12

I am have a strange problem with my bluetooth setup. I recently purchased a new T760s ThinkPad that I am pretty certain has an internal bluetooth device. In fact, I have a very vivid memory of actually testing and connecting some wireless headphones successfully right after installing 16.04 on the machine a few weeks ago. Now, however, there is no more bluetooth icon in the top right near the wirless/time/language/etc.

Furthermore, when I go to Settings>>Bluetooth, I see a a message that "No Bluetooth found Plug in a dongle to use Bluetooth". I've google the shit out of this and come up with absolutely nothing. And the results are weird. There are a small few pages mentioning these exact phrases, and the vast majority of them are gnome translation pages: https://www.google.com/#q=ubuntu+%22No+Bluetooth+found%22+%22Plug+in+a+dongle+to+use+bluetooth%22

Here are some outputs from my system:

$ dmesg | grep -i blue
[ 9.568979] Bluetooth: Core ver 2.21
[ 9.568992] Bluetooth: HCI device and connection manager initialized
[ 9.568995] Bluetooth: HCI socket layer initialized
[ 9.568997] Bluetooth: L2CAP socket layer initialized
[ 9.569001] Bluetooth: SCO socket layer initialized
[ 9.583374] thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is unblocked
[ 9.591541] Bluetooth: hci0: Bootloader revision 0.0 build 2 week 52 2014
[ 9.597556] Bluetooth: hci0: Device revision is 5
[ 9.597558] Bluetooth: hci0: Secure boot is enabled
[ 9.597559] Bluetooth: hci0: OTP lock is enabled
[ 9.597560] Bluetooth: hci0: API lock is enabled
[ 9.597561] Bluetooth: hci0: Debug lock is disabled
[ 9.597562] Bluetooth: hci0: Minimum firmware build 1 week 10 2014
[ 9.599116] Bluetooth: hci0: Found device firmware: intel/ibt-11-5.sfi
[ 9.797731] Bluetooth: hci0: Failed to send firmware data (-19)
[ 10.066047] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 10.066050] Bluetooth: BNEP filters: protocol multicast
[ 10.066053] Bluetooth: BNEP socket layer initialized


$ sudo lsusb |grep Bluetooth
$


$ sudo /etc/init.d/bluetooth status
● bluetooth.service - Bluetooth service
Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2017-01-23 21:35:24 PST; 21h ago
 Docs: man:bluetoothd(8)
Main PID: 1032 (bluetoothd)
Status: "Running"
CGroup: /system.slice/bluetooth.service
       └─1032 /usr/lib/bluetooth/bluetoothd
Jan 23 21:35:24 netnet systemd[1]: Starting Bluetooth service...
Jan 23 21:35:24 netnet bluetoothd[1032]: Bluetooth daemon 5.37
Jan 23 21:35:24 netnet bluetoothd[1032]: Unknown key AutoEnable in main.conf
Jan 23 21:35:24 netnet bluetoothd[1032]: Starting SDP server
Jan 23 21:35:24 netnet bluetoothd[1032]: Bluetooth management interface 1.10 initialized
Jan 23 21:35:24 netnet systemd[1]: Started Bluetooth service.


$ sudo /etc/init.d/bluetooth restart
[ ok ] Restarting bluetooth (via systemctl): bluetooth.service.

Does anyone have any clues? Yesterday I did install a good number of packages, which I ultimately removed, purged, then ran autoremove, and this screwed up my system. I couldn't log in after that and had to reinstall ubuntu-desktop in maintenance more. I am not sure if I fat fingered something or what, and maybe that's not related. I haven't been paying attention to bluetooth until today, so am not sure if its disappearance coincides with my screw up yesterday, of if it disappeared before that. I'm just kind of grasping at straws here.

Thanks in advance.

3 Answers 3

7

On my new Dell XPS with Ubuntu 16.04 installed by Dell, Bluetooth would disappear from time to time. The little Bluetooth icon in the top right-hand part of the panel disappeared. When bringing up Bluetooth with the settings menu, it would be grayed out with no option to start it.

After struggling with this for a time, I discovered that by rebooting the machine AND pressing F2 to enter the UEFI (BIOS) then exiting that immediately, Bluetooth would reappear after login. I would then reconnect my device, a Logitech Bluetooth mouse - this was just pulling a dropdown menu from the Bluetooth icon, selecting the mouse, and clicking "ON".

This works every time for me. I hope it does for you.

1

What I found (bluetooth somehow got soft blocked):

$ rfkill list all
0: tpacpi_bluetooth_sw: Bluetooth
    Soft blocked: yes
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

How I fixed it:

sudo rfkill unblock all

Credit: https://ubuntuforums.org/showthread.php?t=1847809

Unlike the OP form the above link, I was able to restart and see my bluetooth top-bar option after that.

PLEASE NOTE: I still get the "No Bluetooth Found Plug in a dongle to use Bluetooth" when going to Settings>>Bluetooth. But, the bluetooth icon is back in the main top bar, and I can select "Bluetooth settings" from there to get around the Settings>>Bluetooth problem. It makes no sense. And the audio quality is just as I remember it... very shitty :)

EDIT: I spoke to soon. After disconnecting my wireless headphones, the softblock came back. Initiating sudo rfkill unblock all and adding blacklist tpacpi_bluetooth_sw it seems to be working right now, after reboot. But, I was greeting with a system error report upon booting up this time. Sigh. If that continues, I'll remove the blacklist.conf line and just let it block itself naturally again. Testing suggests that turning bluetooth off through the top-bar option will trigger the softblock, requiring rfkill unblock to get it back up. This must be a bug. I don't see the same behavior for the same Ubuntu version running on T450s. Either way, the sound quality is so poor that I'm not sweating it, but still kind of curious as to what's going on. If anyone has advice for improvement, I'm all ears.

0
1

Besides trying all suggestions out there, the only thing that really fixed the issue for me was to update my BIOS to the most recent version.

Essentially follow the following steps:

  1. Download the BIOS from your hardware provider[Intel in my case]. Save it onto a USB drive.
  2. Reboot your machine and and press F7 during boot. This key might be different based on your hardware.
  3. Select the bios file you'd downloaded and let the bios upgrade. On reboot your Bluetooth should be back and functional.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .