6

the maximum available speed for mouse is not very comfortable. i want to increase it.. how to do that?? is there an app to customize these sort of stuffs (preferable since I am new to ubuntu). thanks in advance

13
  1. Run in terminal xinput --list --short and find your mouse id (for me id=12)

  2. Run in terminal xinput --list-props 12 (change 12 for the right id)

  3. Find the id for the property Device Accel Constant Deceleration (for me 262)
  4. Run in terminal xinput --set-prop 12 262 0.1 (change 12 and 262 for the correct id)

The last number (0.1) is the important value. The smaller the number the faster your cursor moves (default value is 1.0). Play around with the values till you find one that works for you and then add the command to the startup applications GUI.

Good luck


1

The first place to speed up your mouse is in Settings -> Mouse and Touchpad -> Pointer Speed.

If that maximum is not enough try this answer : How can I increase the mouse pointer speed beyond the limits set by the Mouse preferences dialog?

Basically, add the following command to Startup Application and change the second number (2 in this case) to the desired mouse speed (2X faster, 3X faster...).

xset m 2 1

Good luck

  • I tried doing this.. i even tried the xset m 5000 1.. it doesn't make any difference in my mouse speed – Karthikeyan Saravanabavan Jan 25 '17 at 15:49
  • @KarthikeyanSaravanabavan please see second answer – staad Jan 25 '17 at 23:28
0

I found a way to fix it after an update from 16.04 to 18.04 (mouse became too slow after the update).

Like in this answer: https://askubuntu.com/a/876273/391744

but change instead just the acceleration profile from 0 to 2:

  1. Run in terminal xinput --list --short and find your mouse id (for me id=12)

  2. Run in terminal xinput --list-props 12 (change 12 for the right id)

  3. Find the id for the property Device Accel Profile (for me 267)

  4. Run in terminal xinput --set-prop 12 267 2 (change 12 and 267 for the correct id)

  • The acceleration doesn't go above 1.0 on my system. To speed up my high dpi mouse I had to alter the transformation matrix as described here: unix.stackexchange.com/a/177640 – joe Oct 1 '19 at 9:22
0

For a GUI tool try typing this into your Terminal:

dconf-editor

For (Ubuntu-Mate-18.04.02) I use the Default of (-1) for both. My settings are here:-

/org/mate/desktop/peripherals/mouse/motion-acceleration

/org/mate/desktop/peripherals/mouse/motion-threshold

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.