0

I am trying to build the purple-facebook pidgin plugin on my system running Ubuntu 16.10/gnome 3, according to the guide I found here: https://github.com/dequis/purple-facebook/wiki/Building-on-*NIX

I have installed all the relevant *-dev and I get an output like this when I run ./configure:

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc understands -c and -o together... yes
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking how to print strings... printf
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking how to convert x86_64-unknown-linux-gnu file names to x86_64-unknown-linux-gnu format... func_convert_file_noop
checking how to convert x86_64-unknown-linux-gnu file names to toolchain format... func_convert_file_noop
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for ar... ar
checking for archiver @FILE support... @
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for sysroot... no
checking for a working dd... /bin/dd
checking how to truncate binary pipes... /bin/dd bs=4096 count=1
checking for mt... mt
checking if mt is a manifest tool... no
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking whether make supports nested variables... (cached) yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GLIB... yes
checking for JSON... yes
checking for PURPLE... yes
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating Makefile
config.status: creating pidgin/libpurple/protocols/facebook/Makefile
config.status: executing depfiles commands
config.status: executing libtool commands

I think this means it's successful, as I've run it a few times when I did not have all the correct files in /usr/lib/pkgconfig and it gave me errors. This time it did not. When I run make install, though, I get this:

Making install in pidgin/libpurple/protocols/facebook
make[1]: Entering directory '/home/joseph/Downloads/purple-facebook-0.9.0-c9b74a765767/pidgin/libpurple/protocols/facebook'
make[2]: Entering directory '/home/joseph/Downloads/purple-facebook-0.9.0-c9b74a765767/pidgin/libpurple/protocols/facebook'
make[2]: Nothing to be done for 'install-exec-am'.
 /bin/mkdir -p '/usr/lib/purple-2'
 /bin/bash ../../../../libtool   --mode=install /usr/bin/install -c   libfacebook.la '/usr/lib/purple-2'
libtool: install: /usr/bin/install -c .libs/libfacebook.so /usr/lib/purple-2/libfacebook.so
/usr/bin/install: cannot create regular file '/usr/lib/purple-2/libfacebook.so': Permission denied
Makefile:450: recipe for target 'install-pkgLTLIBRARIES' failed
make[2]: *** [install-pkgLTLIBRARIES] Error 1
make[2]: Leaving directory '/home/joseph/Downloads/purple-facebook-0.9.0-c9b74a765767/pidgin/libpurple/protocols/facebook'
Makefile:720: recipe for target 'install-am' failed
make[1]: *** [install-am] Error 2
make[1]: Leaving directory '/home/joseph/Downloads/purple-facebook-0.9.0-c9b74a765767/pidgin/libpurple/protocols/facebook'
Makefile:410: recipe for target 'install-recursive' failed
make: *** [install-recursive] Error 1

What am I doing wrong? It's worth noting that I previously tried running make and make install when ./configure had not been successful. Have I made something broken in the place where I'm supposed to install the plugin?

  • You will need to use sudo to make install (because it is trying to install stuff in system directories like /usr/lib/) - however you might want to stop and consider using checkinstall instead – steeldriver Jan 24 '17 at 3:10
  • oh wow it was just that? I feel dumb. – gannex Jan 24 '17 at 3:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.