13

I have installed Ubuntu 16.10 on a 120GB hard drisk (sda) and I have a secondary interal hard disk 500GB (sdc) which has nothing else but a folder with video files in it.

When I try to open a video with VLC on that sdc drive I get this error

File reading failed:
VLC could not open the file "/media/"username"/"hardisksdcname"/Videos/"videofoldername"/"videoname".avi" (Permission denied).
Your input can't be opened:
VLC is unable to open the MRL 'file:///media/"username"/"harddisksdcname"/Videos/"videofoldername"/"videoname".avi'. Check the log for details.

The permissions are "read and write" for all (root and others).

When I copy the video to my desktop and then try to play it with VLC (from the desktop source copy) it works but when I try to strictly play it from my SDC hard drive this error appears.

I don't know where VLC stores its log file..

This is how my devices show up

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop1    7:1    0   115M  0 loop /snap/vlc/4  ***<--whats that?***
sdb      8:16   0 447,1G  0 disk 
sr0     11:0    1   1,1G  0 rom  /media/papajo/Ubuntu 15.10 amd64
loop2    7:2    0   228K  0 loop /snap/htop/68
loop0    7:0    0    76M  0 loop /snap/core/714
sdc      8:32   0 465,8G  0 disk 
└─sdc1   8:33   0 465,8G  0 part 
sda      8:0    0 119,2G  0 disk 
├─sda2   8:2    0 102,8G  0 part /
├─sda3   8:3    0    16G  0 part [SWAP]
└─sda1   8:1    0   512M  0 part /boot/efi
sr1     11:1    1   1,5G  0 rom  /media/papajo/Ubuntu 16.10 amd64
  • Have you tried a different video player such as Videos? – Bob Jan 23 '17 at 23:17
  • the default video player can access those files but I want vlc to do it.. on my previous installation it worked fine... – papajo Jan 23 '17 at 23:18
  • Oh well,the only other thing I can think of is to remove and reinstall VLC,but you probably tried that.Sorry,I don't use VLC;so that's the limit of my (Ha)expertise. – Bob Jan 23 '17 at 23:28
12

If you're using the snap vlc, by default it'll be confined. To get around that, remove it:

sudo snap remove vlc

Then install from the command line:

sudo snap install --classic  vlc

This will allow browsing & loading files outside of $HOME

Please note: that on 16.04 with current snapd package this is no longer needed, vlc can browse mounted volumes, obviously same is true for 18.04.

--classic is basically the old --devmode option.

Though atm there seems no way to use hardware decoding with snaps, if that matters to you...

  • 2
    Still doesnt work... what matters to me is to have it the old way... I dont know what snaps are why are they good I dont want them or have any use for them every program that uses snaps is problematic for me... and they make a mess I have like 10 "snaps" partitions of a few MB each which I never created... – papajo Apr 23 '17 at 13:53
  • Then remove the snap & install the repo vlc that's packaged as a .deb – doug Apr 23 '17 at 21:53
  • how? (not only how to remove the snap version of vlc but the snaps themselves too ) because sudo snap remove vlc doesnt do the trick – papajo May 7 '17 at 7:37
  • 1
    What do you mean 'doesn't do the trick'?, run the command, copy & paste the results to a pastebin or just ask on ubuntu forums which is more suitable to interactive problem solving. – doug May 7 '17 at 21:40
  • 3
    I still have the same problem with Ubuntu 18.04! – Peshmerge May 15 '18 at 8:39
2
sudo snap remove vlc

Then install it using APT:

sudo apt-get install vlc
  • 2
    This is a copy of @doug answer above ... just without useful commentaries. – Soren A Dec 12 '18 at 14:51
  • 1
    sudo snap install --classic vlc didn't work for me. I installed it using apt and only after that was it loading files outside of $HOME – Andrei Gabriel Grimpels Dec 16 '18 at 8:40
  • 1
    I have a clear installation of Ubuntu 18.04 and I had the same problem reported in the question. This solution worked perfectly for me and solved the problem of not accessible devices from VLC without using snap packages. – Luca Ferraro Feb 25 at 18:16
0

There are two different versions of VLC in Ubuntu Software. Try downloading version "3.0.4-1ubuntu0.2" (look for the star rating), uninstalling the previous version (3.0.6) and installing the aforementioned version fixed the issue for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.