1

I followed the instructions from TechApple on how to install an android emulator. I followed all the steps, restarted the pc, but now I still cannot have my android avd command recognized.

The very top of my ~/.bashrc file is :

export PATH=${PATH}:~/android-sdk-linux/platform-tools

The error I get is :

alex@alex:~/android-sdk-linux/platform-tools$ android avd
android: command not found

What do I have to do next in order to get my emulator working?

5

In order to run emulator from terminal you need to -

cd /usr/local/android-sdk-linux/tools/
./emulator -list-avds

This will show all emulators. To choose your emulator -

./emulator -avd <avd_name_shown>
2

On Linux, if you want to run a program that's located in the same folder you're in, you have to use ./ in front of the file name.

Just type ./android avd followed by the rest of the parameters if any.

  • Still does not work. I've tried it and I get the same error. – hadarS Jan 23 '17 at 18:56

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.