0

I've been having problems printing from Gnome Ubuntu to a Xerox Workcentre 6027. I've searched the forums and found things that sounded like they should work. I've tried restarting cups, rebooting, shutting down the computer and restarting it 5 minutes later, restarting the printer, shutting down the printer and waiting 5 minutes. Nothing seems to work. Lastly I tried removing the printer and readding it through the printers control panel but I get a pop up that says "Failed to add new printer". It was easy enough to remove the printer but now I can't readd the thing.

  • Please give details about why you can't re-add it. What you do and what happens. – user589808 Jan 23 '17 at 16:05
  • I've added the exact error message and exactly how I got it in the question text. – Charles Angerstein Jan 23 '17 at 17:46
  • What were those things that sounded like they should work? All you probably needed was drivers: support.xerox.com/support/workcentre-6027/file-download/… – user589808 Jan 23 '17 at 18:14
  • I tried sudo service cups restart and lprm sudo service cups restart. Neither had any effect. I have the driver downloaded direct from Xerox. I have checked their site and there is no update. To be clear, the driver used to work flawlessly, then it started not working and I'd have to restart the printer and/or the computer. – Charles Angerstein Jan 23 '17 at 18:55
  • Have you tried to reinstall the driver? – user589808 Jan 23 '17 at 19:12
0

After testing the printer on a Windows computer and another Ubuntu machine it seems the problem is with the router and not the computers or the printer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.