3

How can I install custom Fonts offline? I want to use Bangla fonts in LibreOffice 5

Some words are not showing correctly, for example (গ্রাম) is showing as (গ্ রাম) .

mentioned that I am using ibus-avro as Bangla typing software.

date it is separated not in complex form..(শুক্ র)

How to solve this?

  • I am a beginner to Ubuntu. I used Windows. So I am finding if there is any way like drag and drop of fonts installation like Windows.. – philoopher97 Jan 23 '17 at 17:20
  • The Ubuntu Manual is good reading for Ubuntu beginners. – Gunnar Hjalmarsson Jan 23 '17 at 19:16
4

For Ubuntu 16.04 and above you must install the right language support

Go to System Settings > Language Support > Install / Remove Languages

enter image description here

and select Bangla (or any other languages). Then click on Apply

enter image description here

Mark Complex Text Layout settings in LibreOffice

  1. Open LibreOffice Writer
  2. Form the top menu select Tools > Option
  3. Scroll down the left panel of the Options window to Language Settings > Language
  4. Select Complex Text Layout (CTL) check mark, and select the language such as Bengali.

Select Keyboard layout (if needed)

ibus is not supported any more (I think). If needed select an alternate keyboard layout:

  1. Go to Systems Settings > Keyboard > Text Entry
  2. Use the + icon at the bottom left to add a Bengali keyboard layout in addition to the default English one.

On my computer I have the following choices:

  • Bangla
  • Bangla (India)
  • Bangla (India, Baisakhi)
  • Bangla (India, Baisakhi inscript)
  • Bangla (India, Bornona)
  • Bangla (India, Probhat)
  • Bangla (India, Uni, Gitanjali)

Your mileage may vary.

  • কাজ হয়েছে ধন্যবাদ (Thanks worked) on Libre office.. – philoopher97 Jan 26 '17 at 14:12
  • But my system still showing শুক্ র instead of শুক্র 😔 – philoopher97 Jan 26 '17 at 14:13
  • @user642711 Please ask another question with more details. What do you mean by system? Which app or on which screen? – user68186 Jan 26 '17 at 15:36
  • .. date (On top of the screen, right corner) – philoopher97 Jan 27 '17 at 3:53
  • @user642711 Please ask a new question about system font display. This is not related to LibreOffice. It should be fixed by enabling Bangla System language. I don't use Bangla as system language. May be someone else will be able to help. – user68186 Jan 27 '17 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.