0

Well the updated ATI just came out so I tried to install it. I did the following:

sudo apt-get remove --purge fglrx
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg

Restarted the computer.

I select Ubuntu from GRUB and I get a black screen. I have no idea how to repair this. I previously followed the same instruction for ATI Drivers 11.10 and 11.11 without a problem.

How do I fix this issue so I can boot into Ubuntu and complete the driver installation process?

  • did you download the official driver from the ati website? what version of ubuntu are you running? what is your graphics card? – Ashu Apr 17 '12 at 5:34
1

Reboot into recovery mode, in low graphics mode. Then reinstall your ATI driver:

sudo aticonfig --initial.

If you see nothing again on the reboot, go back into low graphics mode to uninstall the driver.

  • How to reboot into recovery mode, in low graphics... – chazdg Dec 13 '11 at 22:00
  • Here is the link to the wiki: wiki.ubuntu.com/RecoveryMode – bioShark Dec 13 '11 at 22:39
  • Many thanks, I will try this later or tomorrow. ;) – chazdg Dec 13 '11 at 23:04
  • Unfortunately, the most I was able to get was a purple screen with 'Ubuntu" for a split second and then and blank screen again. This is a dual boot machine with Windows 7. Are the instructions different? – chazdg Dec 14 '11 at 0:49
  • Nope. You must make sure you un-install the old driver first. – bioShark Dec 14 '11 at 0:53
1
  1. Boot from Ubuntu Live CD and continue trying Ubuntu 11.10
  2. Chroot into your installation:

    sudo mount /dev/sdaX /mnt && \
    sudo mount --bind /dev /mnt/dev && \
    sudo mount --bind /proc /mnt/proc && \
    sudo mount --bind /sys /mnt/sys && \
    sudo mount --bind /dev/pts /mnt/dev/pts && \
    sudo cp /etc/resolv.conf /mnt/etc/resolv.conf && \
    sudo chroot /mnt
    

    where /dev/sdaX is the root partition.

  3. Install the ati drivers normally

  4. Reboot!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.