I get this error message

NMI watchdog: BUG: soft lockup - CPU#2 stuck for 23s! [plymouthd:305] 

on the startup of my system (even with live-cd).

My PC is a dell inspiron 7559 with intel graphic and nvidia.

UPDATE - this issue also happens when attempting to install ubuntu 18.10 using LiveUSB

up vote 23 down vote accepted

I also have the same laptop: Dell Inspiron 7559. I managed to boot by adding nouveau.modeset=0 to GRUB's linux line.

When you are in the GRUB menu, press E to enter the GRUB editor. Add nouveau.modeset=0 to the end of the line that starts with linux. After you've added it, press F10 to boot. Your system should start. After that, go to System Settings > Software & Updates > Additional Drivers and then select the NVIDIA driver. Right now I'm using NVIDIA binary driver- version 367.57 from nvidia-367 (proprietary, tested).

However I also have problems. Firstly, the NVIDIA card consumes a lot of power. My battery life is 2 hours with Linux (because it only uses NVIDIA GTX 960). With Windows I get 6 hours if I use it mildly. If I do prime-select intel, and try to log off, it gets stuck and I have to reboot it multiple times to make it boot. Sometimes it never boots back so I have to boot in recovery and switch back to NVIDIA by prime-select nvidia. I have installed all the Dell graphics card drivers and nothing changed - still doesn't boot with Intel selected. However once I managed to boot with Intel and it gave me 6:30 hours of battery life. Something is weird.

  • Also I managed to solve my problems! Now I have like 6:30h battery life. link check this guide out. Make sure that you follow the instructions. – Kaan Goksal Feb 10 '17 at 15:15
  • Thanks for the solution, adding "nouveau.modeset=0" in /etc/default/grub solved my boot issue with Ubuntu 17.04 an kernel 4.10.0-28, too. I have a DELL XPS 9560. – minni Jul 19 '17 at 19:46
  • omg this fixed my laptop, thank you!! – pipo17171 Jan 21 at 15:54
  • I'm using Mint and had the same problem with my Dell laptop. Replacing 'quiet splash' with 'nomodeset' on the grub linux line as described in the Mint release notes works for me. Just adding this here in case other Mint users arrive here. – Neutrino Mar 2 at 12:31
  • This worked for Ubuntu 18.10 on Dell XPS. This allowed me to ctrl-alt-f4 to a console and install the Nvidia proprietary driver. apt-get install nvidia-driver-390. Machine locked up after 12 seconds without this – Kingsley Oct 19 at 20:57

On MSI GP72 6QF Leopard Pro, I have installed Ubuntu 16.04. I installed the latest MSI BIOS firmware update as of 12/2016. Also, I have secure boot disabled and C-step disabled. Since fresh install, the Ubuntu shutdown was halting with the error:

NMI watchdog: BUG: soft lockup - CPU#5 stuck for 22s! [plymouthd:9203]

I'd get different CPU number with each shutdown.

Enabling Nvidia proprietary driver resolved the error and shutdown is successful. To enable NVIDIA driver:

In System Settings, go to Additional Drivers > Nvidia Corp > Enable Using Nvidia binary driver - version 367.57 from Nvidia...(proprietary..)

Enjoy.

  • the problem is that i can't finish to boot the system cause systemd is blocked by this error.you had this problem on the shutdown, I have it on the startup – TheUnderground95 Feb 6 '17 at 10:35
  • Well darn. I have an MSI dual booting to Ubuntu and it has the same soft lockup shutdown error. This seemed promising so I found the "Additional Driver" setting and, sure enough, it wasn't using NVIDIA's. Unfortunately, changing it didn't seem to help. Still need hard reset to shutdown Ubuntu. – M T Nov 22 '17 at 17:24

If your computer has an NVIDIA GPU add nouveau.modeset=0 kernel option to /etc/default/grub . Open the terminal and open /etc/default/grub for editing with nano text editor.

sudo nano /etc/default/grub

Append nouveau.modeset=0 inside the quotes of the line GRUB_CMDLINE_LINUX_DEFAULT="..."

Then update your grub settings with sudo update-grub .

Nano editor keyboard shortcuts
Use the keyboard combination Ctrl + O and after that press Enter to save the file to its current location.
Use the keyboard combination Ctrl + X to exit nano.

I ran into this error booting a gparted live USB and was able to resolve it by choosing the safe graphics options.

  • 2
    Can you add some details on how that is done to this answer? – fakedad Nov 9 '17 at 3:02

At the GRUB menu, select Advanced options for Ubuntu and choose a kernel with recovery mode.

In recovery mode, select the option to <Resume normal login> (or similar).

After logging in go to Software & Updates > Additional Drivers and switch to the Nvidia proprietary driver.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.