My computer at work which runs 11.10 exclusively, has been very very quiet for a few weeks now. I am not sure when exactly the sound stop working but it was after the upgrade to oneiric since I remember listening to music just before the upgrade. I tried many suggested solutions out there but it still does not want to work. Its not a case of sound being mute or lowered.

When I play music I can see activity in the pulse audio volume control (under the playback tab there is a progress bar that shows activity). But there is no sound coming out of either front or rear 3.5mm jacks or the HDMI (through monitor). I have Unity, Gnome3 and XFCE installed side by side and neither of them make a squawk! Anyways, I really like to know how to debug and fix this issue. I am comfortable using the terminal, and if you guide me I can provide debug info. What can I do to find out what the issue is and to fix it?

Sound is onboard:
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
03:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)

Update 1: As pointed out by fossfreedom in the comment, the issue seems to be in the device for sound output. Somehow my real devices have been replaced with a "dummy device". How can I add my on-board sound device to this list? enter image description here

Update 2: I tried running sudo alsa force-reload as suggested and here is the error I get:

sudo alsa force-reload 
Unloading ALSA sound driver modules: snd-intel8x0 snd-ac97-codec snd-hdacodec-hdmi
snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-seq-midi 
snd-rawmidi snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc 
(failed: modules still loaded: snd-hda-codec-hdmi snd-hda-codec-realtek
snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-timer snd-page-alloc).
Loading ALSA sound driver modules: snd-intel8x0 snd-ac97-codec snd-hda-codec-hdmi
snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-seq-midi
snd-rawmidi snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc.

Update 3: Here is the detailed list of my sound devices as requested:

sudo lshw -class multimedia
   description: Audio device
   product: High Definition Audio Controller
   vendor: nVidia Corporation
   physical id: 0.1
   bus info: pci@0000:03:00.1
   version: a1
   width: 32 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list
   configuration: driver=HDA Intel latency=0
   resources: irq:17 memory:fbefc000-fbefffff
   description: Audio device
   product: 82801JI (ICH10 Family) HD Audio Controller
   vendor: Intel Corporation
   physical id: 1b
   bus info: pci@0000:00:1b.0
   version: 00
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list
   configuration: driver=HDA Intel latency=0
   resources: irq:56 memory:f9cf4000-f9cf7fff

Update 4: This is getting interesting. I thought I found the solution when I saw that my user did not have permission to use the sound device. enter image description here

So I add myself to the audio and video groups and rebooted. Now the sound devices are available under choose a device for sound output. enter image description here With lots of hope I selected Internal Audio Analog Stereo as the device, but still no sound at all is coming out of the system :(. I tried using the speaker test tool as well as playing music while trying out all the different jacks. I also tried switching between HDMI and the Internal Audio, still no luck. What else can I do next?

  • 1
    in your sound settings - what is your "device for sound output" and connector set to? What is your Hardware tab set to? What sound device are you jacks connected to (nvidia or intel)? – fossfreedom Dec 13 '11 at 19:42
  • This is interesting ... somehow I have completely overlooked "device for sound output tab". I think you found the issue, the only device there is called "Dummy Output stereo", boy does that make me feel dumb :P! Anyway, I still need help to add proper sound device there. How can I do that? – Aras Dec 14 '11 at 20:29
  • Ok you are really onto something here fossfreedom. I edit the post and add the error I get after running sudo alsa force-reload. What is the next step? – Aras Dec 14 '11 at 20:53
  • The sound devices show up in alsamixer and everything seems normal there. Volumes are all the way up and nothing is muted. Mixer lists four devices as follows: HDA Intel (alsa mixer), HDA NVidia (alsa mixer), Playback: Dummy Output (PulseAudio Mixer), and Capture: Monitor of Dummy Output (PulseAudio Mixer). I have added the output of lshw as requested. – Aras Dec 14 '11 at 21:44

Default sound drivers to original setup

  1. Run sudo apt-get install --reinstall linux-image-$(uname -r)

Setup surround

  1. Edit alsa-base.conf with gksudo gedit /etc/modprobe.d/alsa-base.conf

  2. Add to bottom, options snd-hda-intel model=auto

  3. Restart computer

  4. Open the console and run alsamixer and turn up audio on all and set channels to 6.


Try to manually start the drivers. Since Ubuntu recognizes the devices it should just be a driver problem. First open terminal and run this code:


After that finishes try to play something and if you hear sound that is a good and bad thing. The good part is that your device works, the bad you are going to have to manually force you computer to load the drivers. To do this go back to the terminal and type:

gksudo gedit /etc/modules

Then add your sound driver name to the last line of the file, save, and then reboot.

  • There are 208 possible modules starting with snd-*. How do I know which one is the right one for my sound card? – Aras Dec 14 '11 at 20:58
  • I tried loading two modules (one by one) that had the word intel in them. I get no error, but there is no sound either. sudo modprobe snd-intel8x0m and sudo modprobe snd-intel8x0m. And there is still only the dummy device showing up as sound output. – Aras Dec 14 '11 at 21:09
  • Oops, copy paste mistake. The second one did not have the m at the end: sudo modprobe snd-intel8x0. Anyhow, what is the way to find out which module is appropriate for my sound card? – Aras Dec 14 '11 at 21:26
  • hmm so you tried the first code and didn't get an error but sound did not play. Just double checking but are you sure you typed in the right name for your soundcard driver? – Jakehero Dec 15 '11 at 0:25
  • I know I typed in the name of the two modules above correctly. But I dont know if any of those are the right module for my sound card. That is what I was asking, how can I know what module is the right one to load? What do you mean by [NAME OF YOUR SOUNDCARD'S DRIVER]? How can i find out what that name is? – Aras Dec 15 '11 at 0:33

I have tried this with my fresh install of Ubuntu 11.10, along with several other guides to getting audio working all of them without even a blip from the speakers.

My system uses the intel8x0 drivers ICH7, I have alsa installed but i still cannot get any sound at all to work. According to the information pulled, the drivers are installed, being used, alsamixer is all up full and none muted. The default device is set to my sound card (F6 in alsa mixer)

The device does not show in sound settings its as if it isnt installed when every command to verify is tells me it is.

I have as i said looked over many pages. this is my 3rd day at it. my 4th day as a Linux user. I just wanted to point out this page.


If you take a look down the left side of the page i am sure you will come to the same conclusion as i have, ubuntu and sound are not a match.

I can live without the sound i can always use my very working and stable windows system for that. however i think my linux days are numbered. i prefer to install and work not install fix(maybe) and work. that said its not all bad i guess time will tell.

  • 1
    This is for providing answers not generalizations, consensus or sympathy. I have several other Ubuntu boxes and laptops that I use at home and work and enjoy the sound on them. This particular computer had an issue with the sound and that is why I asked here for help to identify the problem, that is all. – Aras Feb 20 '12 at 16:15

If you have a .pulseaudio or .alsa folder in your home folder , try removing / moving them away so that they are regenerated.

That worked for me when i had upgrade sound / issues


I encountered this problem (or at least a variant of it) after an upgrade from 10.04 to 12.04. I have tried the popular known workarounds such as sudo alsa force-reload and making sure I have the correct drivers loaded with modprobe and the correct model defined in /etc/modprobe.d/alsa-base.conf etc, but recently I also discovered that sudo killall pulseaudio is a possible workaround as well, and that led me to suspect the underlying cause may have more to do with pulseaudio than alsa drivers. I took a leaf from the /etc/rc.local trick I used for How to force Network Manager to set auto negotiation to false/off for a particular NIC (eth0) on start-up? and added killall pulseaudio to it. As crude as it looks this is pretty much the best that can be done right now.

NB: If this works for you (or others) as well, please confirm the report I submitted at https://bugs.launchpad.net/pulseaudio/+bug/933209

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.