1

When I ordered this TP-Link AC1300 Wireless Dual Band PCI-Express Adapter (Archer T6E), I looked into customers reviews and they said it worked fine with no drivers on Ubuntu. I didn't have a CD/DVD player on my desktop so I (on a laptop with a DVD drive) copied and pasted the DVD support disk content on to a USB drive and used that. But when I tried to run autorun.exe it puts up archive manager and says An error occurred while loading the archive Ubuntu verison- Ubuntu 16.04 LTS.

Output from: lspci -vnn

02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 11)
Subsystem: ASRock Incorporation Motherboard (one of many) [1849:8168]
Kernel driver in use: r8169 
Kernel modules: r8169

I am fairly new to Ubuntu (1 month) and have learned alot (sudo commands) and now know that windows is overpriced and that ubuntu is better in most fields.

Thanks for the help.

  • 2
    *.exe files are executable on Windows but not in Ubuntu. So you don't need to run autorun.exe. – Manish Kumar Bisht Jan 23 '17 at 4:22
  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command. Your output shows only the Ethernet adapter. – Pilot6 Jan 23 '17 at 5:54
  • Hi, did you manage to run it just by setting proprietary drivers? I need to know before buying it – Lucas Zanella Feb 13 '20 at 4:11
2

You could build the linux driver from source, but it requires a good amount of linux experience

My repo here:

sudo apt-get install git linux-headers-amd64 build-essential
git clone https://github.com/nyetwurk/linux-wifi-88x2bu-driver
cd linux-wifi-88x2bu-driver
make
sudo make install
sudo modprobe 88x2bu

Verified to work with hostapd (AC1300 Archer T4U) 802.11ac

ID 2357:0115 TP-Link 802.11ac NIC
1

I found this post on ubuntu-forum which mention the wifi-card you are using. So I'm going to instruct you to enable proprietary drivers.

Proprietary Drivers are not generally available by sudo apt-get update. You should go to

system settings -> software & updates

Software Updates

and click on the Additional Drivers tab. There you should see proprietary drivers available for use.

Proprietary Softwares

In your case, details of software should indicate that the driver is for "Using Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source (proprietary) Card. You should tick the radio button which will enable the use of the driver. Then apply changes.

I hope it resolves your issue.

0

I have never actually used any media (CD/DVD) bundled with a new router/gateway ... those devices are stand-alone and just talk http which is universal ... no driver updates required

Typically to define settings you connect using an ethernet cable or point your browser to your router using a special IP ... google : what ip is my router

By default, most router manufacturers use 192.168.0.1 or 192.168.1.1 as the default LAN IP address. This is the address you would enter into your browser's address bar to access the router configuration page

just goto
http://192.168.0.1

  • 3
    This is really not answering the question. – Uzer Jan 22 '18 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.