I recently got a new Dell XPS 13 9365 2-in-1 laptop, I've installed Ubuntu 16.04.1 on it ( kernel 4.8.0-34-generic ) and I noticed that every time I close my laptop lid ( which sends the computer in Suspend mode ) I can not return from Suspend. If I manually go into Suspend mode ( using the GUI not by closing the lid ) I also can't return from that.

Things I've already tried:

sudo apt-get update
sudo apt-get upgrade 

which for what it's worth mentioned this before finishing (not sure if it's an issue or not)

W: Possible missing firmware /lib/firmware/i915/kbl_guc_ver9_14.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_guc_ver8_7.bin for module i915

Some have suggested it could be a brightness issue, which can be corrected in BIOS, but if that were the case I would assume that I would be able to ssh into my machine from another computer, and I cannot ssh into it after going into Suspend (which makes me think it's not simply a brightness issue, but is in fact stuck in Suspend mode)

I tried this script posted on Ubuntu Forums which did not work. It says it's an automated way of doing what you could do manually with Ctrl+Alt+F1 and Ctrl+Alt+F7 but those shortcut keys also do nothing for me after trying to return from Suspend (they do of course work normally, when I'm not in Suspend).

I attempted to try this fix from Ubuntu Forums which references answer #7 in this other thread. I was confused as to exactly how I should substitute the "XXXX:XX:XX.X" in the example, but seeing as how it seemed like a variation on the script I tried before (also in /etc/pm/sleep.d/) I moved on to trying the next thing

I then tried this one Blank screen after resume - Dell M5510 Ubuntu 16.04 but this also didn't solve my problem

I also installed laptop-mode-tools as someone suggested, but wasn't sure how to use this to address the issue.

I should also mention that I had a wireless card issue when I first installed Ubuntu, and that was fixed this way Wireless not working on Dell XPS 13 9365 Ubuntu 16.04 I mention this because it involved updating my kernel (which again is 4.8.0-34-generic) and in one post about Suspend issues they mentioned that it could be caused by the wireless card changing its status XPS 13 9343 Failure to resume from suspend

I hope this can be fixed, thanks in advance!

  • If I read correctly, you have a very new processor. Firmware might be an issue. See here. Jan 22, 2017 at 21:52
  • I cannot comment here, but I answered here Aug 23, 2017 at 12:29
  • that worked @DenisPitzalis thnx so much!
    – Nick Briz
    Aug 25, 2017 at 14:20

5 Answers 5


finally! a solution! @DenisPitza posted in the comments to my question a solution that worked for me! his original post is here i'm reposting his answer below for convenience:

to make permanent the solution proposed by @user8211580 you should edit your groub config file with:

sudo vi /etc/default/grub

edit the line containing


and make sure to include "mem_sleep_default=s2idle" like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash mem_sleep_default=s2idle"

and then reload grub:

sudo update-grub

Then make sure that you do not have any action linked to you power button. Next time you suspend your computer, you'll be able to wake it up by pressing your power button for 6 seconds.



The 9365 only supports suspend to idle (also called "freeze" in linux). It will show the behavior you describe when you try to use suspend to ram, which is the default unfortunately.

This answer is similar to Nick's answer that proposes to change the linux command line using grub. In fact my proposal has exactly the same effect, but by editing another system file.

Just add the following to the file /etc/systemd/sleep.conf:


See the systemd-sleep.conf manual for further information.


I've been able to wake my 9365 by pressing and holding the power button until the screen turns back on. I've noticed that I lose the touchpad when it wakes, and rmmod/modprobing psmouse doesn't bring it back. The touchscreen is still responsive, however. I'll let you know if I find a workaround more acceptable than doing a full shutdown when I want to put the laptop away for a while.

  • 1
    thnx Andrew. When I hold the power button it just shuts off :-/ in the meantime I have my power settings to "Do Nothing" while lid is closed ( what i do is lock the screen before closing it )... not the best solution, just how i'm dealing with it for now. I've been meaning to try Doug's suggestion, but need to find time to back up my system first ( firmware changes like that make me nervous )
    – Nick Briz
    Jan 31, 2017 at 3:41

Resume works for me in 4.10 (you can install one from kernel-ppa -- there's 4.10-rc6 available as of today) - it works in the sense that you can resume from sleep but only by holding the power button for a long time (5s+). Everything seems to work after resume.

I'm running stock 16.04 with 4.10 installed from kernel-ppa and firmware for wifi and i915 (kbl_*) manually installed.

  • apologies for the noobish question, but i rarely ever mess with my kernel, what's the best way for me to upgrade to 4.10?
    – Nick Briz
    Feb 10, 2017 at 15:50
  • ok i got up to speed on updating kernels and updated to the latest, which at this point is 4.10-rc7 (kernel.ubuntu.com/~kernel-ppa/mainline/v4.10-rc7 ) however after rebooting several times ( confirming the update via uname ) and trying different methods of suspending ( closing the lid, using the GUI ) i still can't resume from sleep ( even by holding the power button for 5s+ ) :(
    – Nick Briz
    Feb 12, 2017 at 18:13

Since you are running an LTS release you have a couple options to try and fix your issue. The supported one is installing one of the HWE (hardware enablement) kernels that basically back ports newer hardware support.

Use apt search hwe to see your options, there are slightly optimized versions depending on your current kernel. Check that with uname -a.

Another option is to install a mainline kernel to see if one of the newer kernels works better. This can be troublesome as the mainline kernels don't have distribution specific optimizations which includes some hardware fixes or power management tweaks.

There is an answer around here somewhere on the easiest way to install the latest mainline kernels.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .