7

Is there a repository that provides vim 8 for ubuntu 16.10? The repository indicated here does not work on 16.10 (see also here)

8

[OPTION 1]

In Ubuntu 16.04 following trick worked.

Try via ppa:jonathonf/vim

sudo add-apt-repository ppa:jonathonf/vim
sudo apt update
sudo apt install vim

Check vim version with following command.

vim -version

[OPTION 2]

But for 16.10, build from git source will be a solution as your link describe.

[OPTION 3]

Another option. Download binaries and install with dpkg manually. When I install vim, its dependency vim-common, vim-runtime, xxd and vim-tiny are also installed. Following commands will be install vim and those dependencies. Commands should be run one by one.

xxd

wget http://ppa.launchpad.net/jonathonf/vim/ubuntu/pool/main/v/vim/xxd_8.0.0206-0york1~16.04_amd64.deb
sudo dpkg -i xxd_8.0.0206-0york1~16.04_amd64.deb

vim-common

wget http://ppa.launchpad.net/jonathonf/vim/ubuntu/pool/main/v/vim/vim-common_8.0.0206-0york1~16.04_all.deb
sudo dpkg -i vim-common_8.0.0206-0york1~16.04_all.deb

vim-runtime

wget http://ppa.launchpad.net/jonathonf/vim/ubuntu/pool/main/v/vim/vim-runtime_8.0.0206-0york1~16.04_all.deb
sudo dpkg -i vim-runtime_8.0.0206-0york1~16.04_all.deb

vim

wget http://ppa.launchpad.net/jonathonf/vim/ubuntu/pool/main/v/vim/vim_8.0.0206-0york1~16.04_amd64.deb
sudo dpkg -i vim_8.0.0206-0york1~16.04_amd64.deb

vim-tiny

wget http://ppa.launchpad.net/jonathonf/vim/ubuntu/pool/main/v/vim/vim-tiny_8.0.0206-0york1~16.04_amd64.deb
sudo dpkg -i vim-tiny_8.0.0206-0york1~16.04_amd64.deb

[OPTION 4]

As @CelticWarrior's suggestion, we can also try with apt-add-repository.

sudo add-apt-repository "deb http://ppa.launchpad.net/jonathonf/vim/ubuntu xenial main"
sudo add-apt-repository "deb-src http://ppa.launchpad.net/jonathonf/vim/ubuntu xenial main"

After adding repository with xenial source.

sudo apt update
sudo apt install vim
  • Unfortunately this is the one that doesn't work. – supersambo Jan 22 '17 at 18:29
  • Sorry. I updated my answer. You have already found this way. If I have found I will update this answer again. – San Lin Naing Jan 22 '17 at 18:34
  • If Option 3 works, then you can simply edit the PPA and replace yakkety with xenial. Change it back as soon as the PPA has support for 16.10, if ever. – user589808 Jan 22 '17 at 21:41
  • @CelticWarrior, Thanks for your advice. If so we may be able to add with add-apt-repository commands. I will add another Option. – San Lin Naing Jan 23 '17 at 5:03
  • 1
    Notice that ppa:jonathonf/vim wasn't compiled with Python support. – Yamaneko May 5 '17 at 23:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.