3

When I try to install unity tweak tool with

sudo apt-get install unity-tweak-tool

the output is

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 unity-tweak-tool : Depends: unity-webapps-common but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried Synaptic and Ubuntu software center also. I have Ubuntu 16.04 LTS.

3

I'm also using Ubuntu 16.04.

My Ubuntu version

Note : If you have tried installing tweak-tool before please visit Removing Unity-Tweak-Tool first and follow all instruction.

Now to install follow below steps:

  • First open Terminal (Alt+Ctrl+T) and paste sudo apt-get install unity-tweak-tool gnome-tweak-tool.

  • Enter your password.

  • Now it will take 1-2 minutes to install.

  • After installation is finished, you can launch the Tweak-Tool from terminal by typing unity-tweak-tool, OR launch it via Dash.

Tweak-Tool from dash

Try purging the unity tweak tool and reinstalling it(if above one failed to give you desired result).

  • sudo apt-get purge unity-tweak-tool

  • sudo apt-get autoremove && sudo apt-get autoclean

  • sudo apt-get install unity-webapps-common unity-tweak-tool

  • sudo apt-get install unity-tweak-tool

I Hope this time it works for you as it working for me.

  • 'Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: gnome-tweak-tool : Depends: gnome-settings-daemon but it is not going to be installed unity-tweak-tool : Depends: unity-webapps-common but it is not going to be installed E: Unable to correct problems, you have held broken packages. – Random Jan 22 '17 at 8:44
  • try purging unity-tweak-tool – Pankaj Gautam Jan 23 '17 at 5:46
  • use sudo apt-get purge unity-tweak-tool and below commands to install it @Random – Pankaj Gautam Jul 29 '17 at 7:42
1

Found this article so might help you solve the install. See extract of the 2nd option I believe would help install missing dependencies also:

sudo apt-get install gdebi

wget http://archive.ubuntu.com/ubuntu/pool/universe/u/unity-tweak-tool/unity-tweak-tool_0.0.7ubuntu2_all.deb

sudo gdebi unity-tweak-tool_0.0.7ubuntu2_all.deb

unity-tweak-tool
1

I'm using Ubuntu 18.04, it's March 2019 and I've just installed unity-tweak-tool through the terminal this way:

On Ubuntu, open "Software & Updates" screen. Search for it in your dash.

Check The first 4 options, as on the screenshot:

install unity-tweak-tool on Ubuntu 18.04

It will ask to do a update when you save. Allow it.

Open your terminal and install normally: sudo apt-get install unity-tweak-tool

PS: Kudos to this answer.

1
  • Try installing through PPA (personal package archive)
sudo add-apt-repository ppa:freyja-dev/unity-tweak-tool-daily
sudo apt-get update
  • Then install the package from terminal
sudo apt-get install unity-tweak-tool-daily
0

Open the terminal and type:

sudo apt-get -f install unity-webapps-service unity-webapps-common
sudo apt-get install unity-tweak-tool
  • i got a problem when i tried the first command 'Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: unity-webapps-common : Depends: unity-webapps-service (>= 2.3.8-0ubuntu3) but it is not going to be installed E: Unable to correct problems, you have held broken packages. ' – Random Jan 22 '17 at 8:08
  • Edited answer to fix broken packages for unity-webapps-service too. The results of this should be informative because unity-webapps-service has some important dependency packages required by it. – karel Jan 22 '17 at 8:12
  • The following packages have unmet dependencies: unity-webapps-service : Depends: webapp-container E: Unable to correct problems, you have held broken packages. – Random Jan 22 '17 at 12:06
0

I fixed this way:

I had several PPA on the APT configuration and I suspected one or more may cause version issues between dependencies. Looking between PPA names I found a "backport". But how to remove its packages and substitute them with the original repo packages?

sudo apt-get install ppa-purge
sudo ppa-purge ppa:<ppa name you want to remove and purge>/ppa
sudo apt-get install unity-tweak-tool

NOTE: you can install "Y PPA Manager". It is a good GUI tool that includes ppa-purge and can indicate which packages are contained in every PPA. This way you know what you remove.

0

Download qtbase-abi-5-5-1 linux packages for Ubuntu. Then run the following code:

sudo dpkg --force-all -i ~/Downloads/libqt5core5a_5.5.1*
sudo apt install -f

Now install unity-tweak-tool.

0

This was really problematic for me as I had many other cases in which the dependency tree was broken and it was impossible to install or reinstall some packages like unity-tweak-tool.

At the end, the solution was pretty simple. You need only to use aptitude instead of apt-get. It has a smart way to handle broken dependencies. In my case, I run:

sudo aptitude install unity-webapps-common unity-tweak-tool

From there I got to a proposed fix. The first approach proposed was not effective but if you write n instead of Y it will propose you something else (in which there is removing, installing and even downgrading many packages). You type Y and it is done. Following is part of the fix that worked for me:

terminal screenshot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.