1

Recently installed ubuntu 16.04 on dell xps 13 (running on 7th gen i5) but couldn't get sound. I am dualbooting windows 10 and ubuntu 16.04 on my computer. Sound is working fine in windows but not in ubuntu.

Tried a couple of online solutions but none seem to work.

Current status:

  1. When i first launched ubuntu, tried playing a video and there was no sound. Clicked on volume icon on top bar and it showed that there was only the dummy output.
  2. Tried the solution from this: Installed Lubuntu 16.04 version no audio now. Managed to execute all 3 commands, "sudo apt-get remove --purge alsa", "sudo apt-get install pavucontrol" and "gksu pavucontrol". But after the 3rd command, when i opened the pulse audio volume control, it still only showed dummy output, and doesn't have sound/detect my headphone plugged in. Previously at the top bar, there was the volume icon. But after executing the above steps, the icon is no longer there.
  3. Entered "aplay -l", returned "no soundcards found"
  4. Followed instructions from here: https://help.ubuntu.com/community/SoundTroubleshootingProcedure, executed command #1A, returned "rm: cannot remove '/home/jen/.pulse*': No such file or directory."

Am confused as to what i should do next or which online solution to follow as i am unsure what exactly is the issue now. I might have messed up the settings since i have already tried running a couple of commands found online.

Appreciate if someone can help!

  • Check BIOS?UEFI before anything else as the onboard audio might be disabled. If not please edit your question with all you've been doing. – user589808 Jan 22 '17 at 4:02
  • I'm dual booting my laptop with Win10 and ubuntu 16.04, not sure if this matters but sound is working fine in windows. I've also just checked my bios setting, audio is enabled. – Jen Jan 22 '17 at 4:17
  • Ok, please EDIT and update your question with that information plus what did you do before that, what steps/guides/links you followed, etc. – user589808 Jan 22 '17 at 4:19
  • Hi CelticWarrior, just amended my question. Sorry, took my a while because i had to recall the steps i took and concurrently, i'm also facing unstable wifi connections on ubuntu. The wifi gets disconnected every 5 mins but wifi icon still shows that it is connected. I'll have to manually click disconnect and connect again for it to work. Thanks for your help! – Jen Jan 22 '17 at 4:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.