2

My sound no longer works on my new Ubuntu laptop (Dell XPS 13). I dual-boot Windows and Linux on this machine, and I have had some problems with complete lack of sound under both operating systems. The solution for Windows turned out to be a BIOS setting (setting "Fastboot" to "Thorough"); while I realize this has nothing to do with audio, it was a known issue.

On Ubuntu, the occurrence of no sound is a bit more stochastic. At first, changing "Fastboot" to "Auto" in the BIOS settings seemed to work, but after a resume from sleep, sound is gone again. Additionally, immediately after resuming, a dialog pops up and asks what device I just plugged in (headphones, etc.), when I have actually not plugged in anything. This post describes a similar problem and suggests a reboot is the only thing that fixes the problem. Changing the sound source back to speakers and increasing the volume with alsamixer has no effect.

Furthermore, when sound was working yesterday, the system volume controls had no effect on the sound volume.

I cannot find any specific information for this sound card (Realtek ALC3246) under Ubuntu.

My system configuration (used the ALSA info script) is here:

http://www.alsa-project.org/db/?f=a480ccb1bd0b063871459b408e18be241cabfd9f

UPDATE:

I tried forcing I2S sound by following the instructions here. No change, but I'm still running the modified kernel for now.

Then, I found the following fatal error in dmesg:

[   10.980953] snd_hda_intel 0000:00:1f.3: azx_get_response timeout, switching to single_cmd mode: last cmd=0x208f8100

According to the link, the error has to do with codec probing and a possible solution is forcing probes of particular codecs. The combination below forces probing codec slot 0:

options snd-hda-intel probe_mask=0x101

This seems to have fixed the sound through the speakers, at least for now, and the fix still works after a sleep cycle. Furthermore, the volume controls are working again, which is another symptom I didn't immediately notice (since sound was intermittent at best) but was definitely a problem.

  • What BIOS setting was that? – user589808 Jan 22 '17 at 2:53
  • @CelticWarrior, POST Behavior -> Fastboot -> Thorough (changed from Minimal). – emprice Jan 22 '17 at 3:22
  • It has nothing to do with audio. – user589808 Jan 22 '17 at 3:32
  • @CelticWarrior, it was a known issue on Windows and that was the solution; audio started working under Windows after the setting was changed. I don't know much more than that. – emprice Jan 22 '17 at 3:33
  • 2
    Please update your question with all that information, including the BIOS version which hopefully is 1.2.3 (December 14th, 2016). It includes this in its changelog: 3. Add support for Audio Digital Signal Processing (DSP). Also please describe with more details I have had some problems with sound under both operating systems and what exactly is the problem now in Ubuntu (Windows is off-topic). – user589808 Jan 22 '17 at 3:58
2

The error message

[   10.980953] snd_hda_intel 0000:00:1f.3: azx_get_response timeout, switching to single_cmd mode: last cmd=0x208f8100

is described here as relating to a codec probing problem. Adding the line

options snd-hda-intel probe_mask=0x101

to /etc/modprobe.d/alsa-base.conf, which forces probing codec slot 0 independent of what the hardware reports, seems to have fixed the all the problems with both the speakers and the headphones, and it survives sleep cycles.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.