I am trying to use a different DNS server other than my router.

I've tried editing /etc/resolv.conf, but my changes always get overwritten.

Here's my networks' config:

Here is my network's config

Yet, this is what my /etc/resolv.conf file looks like:

# Generated by resolvconf
search myhome.westell.com
  • I would file a bug report with that. The ncurses interface should set your DNS. – Panther Dec 13 '11 at 17:43

I'm having the same problem, i believe the culprit is dhclient, which gets run automatically by wicd. whenever the dhcp lease expires, dhclient overwrites /etc/resolv.conf with what it gets from the the dhcp server.

to verify that this is indded your problem, do "ps aux | grep dhclient", you should an entry pop up, referencing a configuration file for dhclient (on my machine it's at /var/lib/wicd/dhclient.conf).

to fix this, you need to edit /etc/wicd/dhclient.conf.template (NOT /etc/wicd/dhclient.conf.template.default)

and add a line like the following:


then restart the wicd service with

sudo service wicd restart

this will instruct dhclient to set resolv.conf to the manually specified servers, rather then to what your dhcp server (i'm guessing the home router at is sending you.

wicd should really handle this for you, but this will solve your problem for now. seems to solve the issue for me.

| improve this answer | |
  • 1
    Hey there.. so I tried this and it seemed to work, but I started getting "dns lookup failed" and I realized /etc/resolv.conf is being overwritten, with :( – Matt Dec 25 '11 at 1:13

Start wicd by searching for 'wicd' in the dash. Once wicd has been started, select your network and click on "Properties" enter image description here

In the properties dialog box, check 'Use Static DNS' enter image description here

Enter your preferred DNS Servers in the "DNS Server 1, 2 and 3" boxes. The DNS domain and the search domain can be left empty. For example for OpenDNS , I just enter the 2 DNS servers.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.