0

I cannot change the brightness of my HP EliteBook 8760w. When I press the brightness keys, ubuntu shoes the meter going down and up, but the screen brightness does not change.

I am using nvidia drivers 367.57 for the Quadro 3000M.

user@laptop:~$ ls /sys/class/backlight/
acpi_video0
user@laptop:~$ cat /sys/class/backlight/*/brightness 
20
user@laptop:~$ cat /sys/class/backlight/*/max_brightness 
20
user@laptop:~$ sudo su -c "echo 5 > /sys/class/backlight/*/brightness"
user@laptop:~$ cat /sys/class/backlight/*/brightness 
5

Is there anything else I could try to change the brightness?

I tried changing /etc/default/grub to add additional parameters to acpi_backlight. The following happens:

(not defining)  only acpi_video0 exists and brightness does not work
video           only acpi_video0 exists and brightness does not work
vendor          no folder in /sys/class/backlight
native          no folder in /sys/class/backlight
  • Edit /etc/default/grub , add the parameter acpi_backlight=vendor to the variable GRUB_CMDLINE_LINUX_DEFAULT save the file, run sudo update-grub and restart. Here are the references wiki.archlinux.org/index.php/backlight and wiki.ubuntu.com/Kernel/Debugging/Backlight. – Hölderlin Jan 22 '17 at 9:48
  • When I add that option, there is no folder in /sys/cclass/backlight at all! – feedc0de Jan 22 '17 at 17:13
  • Try one of the other parameters which are listed in the wiki of archlinux in section "Kernel command-line options". If you say "screen" do you men a external monitor or the display of your laptop? – Hölderlin Jan 22 '17 at 17:25
  • when i define acpi_backlight=vendor it behaves exactly like without defining. when defining it as vendor or native the acpi_video0 folder is missing completely. i am speaking of the built-in laptop monitor. I know the brightness worked years ago... on some ubuntu dist. – feedc0de Jan 22 '17 at 23:10
  • Try the solution from user:Dabor in this post but use a parameter where the acpi_video0 folder is not missing. What I don't understand that you said one comment before that the parameter vendor gives you no acpi_video0 folder as well. – Hölderlin Jan 22 '17 at 23:18
0

Worked on my Ubuntu 18.04.03:

sudo ubuntu-drivers autoinstall

And then restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.