14

I am trying to extract a .tar.xz file on my Ubuntu Mate computer. No matter what I do, I get this error:

xz: (stdin): File format not recognized
tar: Child returned status 1
tar: Error is not recoverable: exiting now

I have done the following (although my repeated attempts to circumvent the error may highlight my ignorance):

tar xf file.tar.xz

Then,

unxz file.tar.xz #results in file.tar

That time, I got this similar error:

unxz: file.tar.xz: File format not recognized

Then, I did this:

tar -xJf file.tar.xz

Etcetera...

I tried updating/installing tar and xz-utils using

sudo apt-get install xz-utils

for x-utils, and

sudo apt-get install tar

for tar. They both updated/installed successfully, but when I did the above things again, I got the same errors.

EDIT ONE

When I use:

file file.tar.xz

I get

file.tar.xz: HTML document, UTF-8 Unicode text, with very long lines

When I try to open it with Engrampa using

engrampa file.tar.xz

I get the same error mentioned above.

I am running Ubuntu Mate 16.04 on the Raspberry Pi 3.

The output of

apt list xz-utils

is

Listing... Done
xz-utils/xenial,now 5.1.1alpha+20120614-2ubuntu2 armhf [installed]

The output of

xz --version

is

xz (XZ Utils) 5.1.0alpha
liblzma 5.1.0alpha

The output of

tar --version

is

tar (GNU tar) 1.28
Copyright (C) 2014 Free Software Foundation, Inc.
Liscense GPLv3+: GNU GPL version 3 or later <http://gnu.org/lisenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by John Gilmore and Jay Fenlason.

I obtained the file (pepper-flash-v.20.0.0.228r1.tar.xz) by using the command line

wget http://dl.free.fr/qVkzvqSiB -O pepper-flash-v20.0.0.228-r1.tar.xz

EDIT TWO

Thanks for all your answers. This question is closed.

3
  • 5
    Try file file.tar.xz, this should give you a hint on the file type, unless it just says "data". Commented Jan 21, 2017 at 13:26
  • In addition to what Olaf Dietsche suggests, If this is a publicly available .tar.xz, can you give a link to it? What version of Ubuntu Mate are you running? Are you able to unpack the file with the Archive Manager (in MATE this is engrampa rather than file-roller)? What is the output of apt list xz-utils, of xz --version, and of tar --version? Please edit your question with all this information. Thanks! Commented Jan 21, 2017 at 14:14
  • 3
    "file.tar.xz: HTML document, UTF-8 Unicode text, with very long lines" means you downloaded a website and NOT a file.
    – Rinzwind
    Commented Jan 21, 2017 at 14:57

3 Answers 3

11
file.tar.xz: HTML document, UTF-8 Unicode text, with very long lines

indicates that I downloaded a website. That's why it won't extract.

1
  • Indeed, the URL is not the direct address of the file, but that of a download page. You should download the file from a Web browser.
    – fkraiem
    Commented Jan 21, 2017 at 16:18
3

Please do not download files from a random site. The contents of that file could have been altered to mess up you system.

The correct place to download from is the debian wiki page and you download it from their tracker site and here is the direct download. It will download pepperflashplugin-nonfree_1.8.1+deb8u1.tar.xz and after downloading you can use your tar command to extract it.

To install though I would advice to use the normal Ubuntu installation. Enable "Canonical Partners" in Software & Updates and then run ...

sudo apt update
sudo apt install adobe-flashplugin

This will install flash and the pepper flash plugin.

0

In my case, the specified archive file was not downloaded correctly because of a certificate error. Remove -q from wget to see whether you might have the same problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .