0

I have a computer with windows 7 installed that's not booting and decided to install ubuntu on it. I've downloaded ubuntu on a mac and used dd to make a bootable usb. I'm able to boot from the usb and I choose Install Ubuntu.

I choose Install Ubuntu, Erase Disk and Install now but I get this error:

The creation of swap space in partition #5 of SCSI1 (0,0,0) (sda) failed.

So it seems some part of the system is corrupted. I may have mangled it even more trying to fix this. I've googled around and tried lots of solutions that didn't work for me:

  • Instead of Erase Disk I choose Something else. I then try to set up partitions as in this question. Clicking Install now gets me a bit further than before, but after staying on

    Creating ext4 file system for / in partition #5 of SCSI1 (0,0,0) (sda)...
    

    for a while, I get this error:

    The ext4 file system creation in partition #6 of SCSI1 (0,0,0) (sda) failed
    

I Use Try Ubuntu instead and open a terminal. Then try the following:

  • sudo gparted. It gives the following error:

    Invalid partition table on /dev/sda - wrong signature bfd3.
    

    clicking ignore gives

    The driver descriptor says the physical block size is 2048 bytes, but Linux says it is 512 bytes.
    

    I click ignore again and see three partitions:

    Partition | File System | Size | Used | Unused | Flags

    /dev/sda1 | linux-swap | 590.18 GiB | 0.00 B | 590.18GiB |

    /dev/sda2 | extended | 5.99 GiB | - | - |

    unallocated | unallocated | 5.99 GiB | - | - |

    I delete the partitions sda1 and sda2. It repeats the two errors but it seems to have worked; the only thing partition left is unallocated. But after restarting and choosing Install Ubuntu I get the same errors. And using Try Ubuntu and gparted again the partitions are exactly like in the table above once more.

  • I download Boot Repair and run it, as explained here. It seems to work but after restart the problems are the same. The logs can be found here.

  • I download Testdisk and run it as explained here. When running the Analyse I see the following:

     Disk /dev/sda - 640 GiB / 596 GiB - CHS 77825 255 63
     Current partition structure:
     Partition     Start    End    Size in sectors
     1 P Linux swap  0  32  33  62  53  55 997376
     2 E extended   62  86  23  77825  70  5  1249261570
    No partition is bootable
     5 L Linux   62  86 25 2493 172 47 39059456
      X Extended 2493 172 48 77825 70 5 1210202112
    
    test_logical
    Partition sector doesn't have the endmark 0xAA55
    

    so the output is a bit different than in the link. I run Quick Search and get some of the same info again. I then have options to change partition characteristics and to add partition, load backup and change type, but I'm not sure what to do.

  • Running sudo LANG=C sfdisk -d /dev/sda gives"

    Ignoring extra data in partition table 6
    Ignoring extra data in partition table 6
    Ignoring extra data in partition table 6
    Invalid flag 0x9616 of EBR (for partition 6) will be corrected by w(rite).
    label: dos
    label-id: 0x976074d3
    device: /dev/sda
    unit: sectors
    
    /dev/sda1 : start = 2048, size = 997376, type = 82
    /dev/sda2 : start = 1001470, size = 1249261570, type = 5
    /dev/sda5 : start = 1001472, size = 39059456, type = 83
    /dev/sda6 : start = 3022904410, size = 3562462754, type = 77
    

Any ideas?

1

Take backup of the contents of your hdd. If your hdd has physical damage, there is no way to fix it unfortunately. Be warned, this will destroy all your data.

  • Download Ultimate Boot CD and make a bootable disk.
  • Make a second bootable device with Ubuntu with in it.
  • Boot using UBCD, open GParted, manually delete all your drives
  • Choose Create Partition Table from Device. Pick DOS from the dropdown and click apply.

This should fix the pesky The driver descriptor says the physical block size is 2048 bytes, but Linux says it is 512 bytes issue you were having.

  • Quit Gparted, and run a suitable disk checking utility. Scroll down to /HDD/Diagnosis part in UBCD website for reference. Also this step by step guide is good.

If disk checking apps doesn't pick up any bad sectors or errors,

  • Quit UBCD, boot from the another bootable disk that has Ubuntu.
  • Fresh install.
|improve this answer|||||
  • After choosing the UBCD as a boot device I just get a flashing dash, might be the hardware like you said. Thanks for trying! – jorgen Feb 4 '17 at 15:59
  • 1
    @jorgen, you can try with the bootable ubuntu disk. It has gparted, so you'll be able to completely remove and recreate the partition table. Then install ubuntu. However, all your data will be lost, so keep a backup first. – Sirajus Salekin Feb 5 '17 at 0:54
  • I think I tried that already (second bullet point in the OP), unless I'm misunderstanding? – jorgen Feb 5 '17 at 11:33
  • @jorgen I'm sorry if I've misread, but what I understand from OP is you deleted the existing partition. But it does not say if you have completed recreated the partition table (bulletpoint#4 of my answer). If you've done so, and still no luck, I think you should claim for your warranty. – Sirajus Salekin Feb 5 '17 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.