I have an HP Envy notebook, not a touch device/tablet so it should not adjust screen orientation to suit how I hold the device. However, the orientation seems to randomly and spontaneously change, both when I am using the device, and while it wakes from suspend. There is no pattern to which orientation it switches to; sometimes it rotates, sometimes it flips.

xrandr -o normal

correctly re-orientates the screen, but it would obviously be nice if I did not have to keep doing this.

  • it should not adjust screen orientation but the manufacturer disagrees otherwise they wouldn't have included the sensor that makes it happen. It should be possible to disable in BIOS/UEFI.
    – user589808
    Jan 21, 2017 at 16:34
  • @user589808 the sensor is for detecting when the laptop is falling and stopping the hard drive, not for changing screen orientation.
    – dericke
    Nov 10, 2018 at 21:00

2 Answers 2


You can lock the rotation of the screen using the second icon in the top-right menu. The icon looks similar to the icon used for screen rotation in mobile OSes like Android.

In order to disable the functionality permanently (desirable if you do not have a touchscreen :-) ), you can do that by setting dconf-key active in org.gnome.settings-daemon.plugins.orientation to false using either gsettings (CLI) or dconf-editor (GUI).

gsettings set org.gnome.settings-daemon.plugins.orientation active false

In later versions

gsettings set org.gnome.settings-daemon.peripherals.touchscreen orientation-lock true

After logging out and in again, the the button should no longer be there and your screen's orientation should stay as it is.

  • 1
    This doesn't work in Ubuntu 17.10 (using gsetting). Do you know the way to disable the plugin?
    – user502144
    Nov 3, 2017 at 3:23
  • 2
    org.gnome.settings-daemon.peripherals.touchscreen orientation-lock false
    – Rondom
    Nov 3, 2017 at 12:11
  • 1
    It just turns orientation lock on/off, but doesn't disable the plugin. This is built-in functionality now, but not a plugin anymore, isn't it?
    – user502144
    Nov 4, 2017 at 8:08
  • 2
    Looks like it. Really need a way to turn this off because after the screen has tilted, it will only flip between the two portrait modes, but will not get back into landscape.
    – retorquere
    Nov 9, 2017 at 7:03
  • Is there any keyboard shortcut that permits one to reorient the screen quickly when this arrives? When the screen is upside down, it is hard to get into applications, settings and terminals. Oct 21, 2018 at 14:52

The easiest way is using dconf-editor, going to:


Disable "Use default value" and set "TRUE" as custom value.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.