I am a heavy user of certain applications that are built on AIR.

It appears that AIR has discontinued support for Linux. Even the older versions in the Adobe AIR Archives seem to support only 32 bit Linux distributions and I am on 64 bit currently.

Is there even a slight possibility that I could run AIR in these conditions? If so, can you please tell me where can I get a detailed step by step installation for this?

  • 9
    Note that Adobe have ended support for AIR on Linux. Adobe is also moving away from legacy technologies such as Flash and AIR into HTML5 which is the future.
    – Anonymous
    Dec 13, 2011 at 19:55
  • 1
    I installed adobe air from .deb file in oneric
    – Tachyons
    Apr 9, 2012 at 3:21

9 Answers 9

  1. Download Latest Version Air 2.6.0 For Linux to your Desktop:

Maybe you'll get an error after the last command?

Sorry, an error has occurred. Adobe AIR could not be installed. Install either Gnome Keyring or KDE KWallet before installing Adobe AIR.

This can be fixed:

  • In a terminal (default shortcut: Ctrl+Alt+T), type:

    locate libgnome-keyring.so
  • This is my result (yours might be different):

  • As suggested below by @jmendeth, the easiest way to tell the installer where to find these files is to use LD_LIBRARY_PATH:

    • For 32-bit Ubuntu (tested on 12.04):

      LD_LIBRARY_PATH=/usr/lib/i386-linux-gnu ./AdobeAIRInstaller.bin
    • For 64-bit Ubuntu, the command line would probably be:

      LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu ./AdobeAIRInstaller.bin

If the LD_LIBRARY_PATH trick doesn't work, you can try this:

  • Create a symbolic link to your location strings that you found with the previous commands:

    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
  • Use following commands for 32-bit systems:

    sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
    sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
  • Then repeat step 4 & 6 (skip 5, as the permission to execute the file hasn't changed).

  • Remove symbolic links after installation of Adobe AIR 2.6.0:

    sudo rm /usr/lib/libgnome-keyring.so.0
    sudo rm /usr/lib/libgnome-keyring.so.0.2.0


  • 1
    Great! It's installed. Now if I only can install an AIR package...
    – user33606
    Jun 7, 2012 at 5:27
  • 2
    Doesn't AIR respect LD_LIBRARY_PATH? Just askin' Aug 15, 2012 at 15:45
  • 28
    I created an account just to upvote this +1 Feb 7, 2013 at 23:40
  • 4
    I cannot possibly +1 you enough.
    – Jonah
    Apr 8, 2013 at 6:08
  • 7
    It's not working for me on Xubuntu 13.10. sudo apt-get install ia32-libs Package ia32-libs is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source. However the following packages replace it: lib32asound2 lib32z1 lib32ncurses5 lib32bz2-1.0 ./AdobeAIRInstaller.bin /tmp/air.kmEATV/setup: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory Jan 10, 2014 at 18:07

Ubuntu 13.10, 14.04, 15.04 and 15.10 (64 bit)

  1. Install i386 libraries, that are required for successful installation and running of Adobe Air and air applications.

    sudo apt-get install libxt6:i386 libnspr4-0d:i386 libgtk2.0-0:i386 libstdc++6:i386 libnss3-1d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libcanberra-gtk-module:i386 gtk2-engines-murrine:i386
  2. Install libgnome-keyring0:i386 package.

    sudo apt-get install libgnome-keyring0:i386
  3. Create symlinks to gnome-keyring so Adobe Air could see it.

    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0 
  4. Download Adobe Air installer from here.

  5. Give execute permission and then run that .bin file.

    sudo chmod +x AdobeAIRInstaller.bin
    sudo ./AdobeAIRInstaller.bin


Note for Ubuntu 16.04 (64 bit)

For Ubuntu 16.04 and greater, install the package libnss-mdns:i386 instead of the package lib32nss-mdns. This will solve the problem of "Package not found error" related to that package.

  • So, how do I uninstall Adobe Air? Nov 11, 2015 at 16:34
  • Ubuntu 15.10. Anyone else who need this for e-Deklaracje app ?
    – pawel7318
    Jan 26, 2016 at 20:51
  • Hi all. Pls feel free to update my answer if it works for recent versions. Jan 27, 2016 at 5:39
  • 1
    16.04, got an error that lib32nss-mdns was missing. When installer opened got Gtk-Message: Failed to load module "overlay-scrollbar" Gtk-Message: Failed to load module "gail" Gtk-Message: Failed to load module "atk-bridge". Seems to have installed correctly. But the app I needed AIR for needs a more recent version :/
    – raphael
    Nov 25, 2016 at 4:21
  • @raphael Install libnss-mdns:i386 package instead.
    – Anwar
    Apr 3, 2017 at 14:05

Alternately, you can install a prebuilt .deb

There is air 2.6 (last supported Linux one) available here for both architectures (Both use 32 bit underneath but at least it works). Thanks to prusswan for pointing it out.

Make sure you have 32 bit libs it'll need:

sudo apt-get install ia32-libs

I downloaded the AMD64 one (adobeair_2.6.0.19170_amd64.deb) and installed on my computer (am64 with Precise Pangolin 12.04)

sudo dpkg -i adobeair_2.6.0.19170_amd64.deb

Then I installed the application that needed Adobe Air in the first place and it worked.

Update for Ubuntu 13:10+,

Trying this technique, i get "Package ia32-libs-gtk is not installed"

I looked up the package and tried installing those dependencies and other related packages I can think of directly:

sudo apt-get install gtk2-engines:i386 libart-2.0-2:i386 libcairo2:i386 libcanberra-gtk0:i386 libdatrie1:i386 libgail-common:i386 libgconf2-4:i386 libgtk2.0-0:i386 liblua5.1-0:i386 libpango1.0-0:i386 libpixman-1-0:i386 libqt4-network:i386 libqt4-test:i386 libqtcore4:i386 libthai0:i386 libbonobo2-0:i386 libglade2-0:i386 libgnomecanvas2-0:i386 libidl0:i386 liborbit2:i386 libwmf0.2-7:i386 gtk2-engines-murrine:i386

But that didn't work for either the deb or original binary.

  • 1
    I have searched the internet high and low and your install link is the only one that worked. Note to future visitors: if you're using the AdobeAIRInstaller.bin and getting a Gtk WARNING **: cannot open display: error, try this!
    – elemjay19
    Apr 18, 2013 at 23:59
  • 1
    this is much easier than jeffhendricks.net/?p=68
    – realgt
    Apr 24, 2013 at 13:32
  • Dug a little deeper than nora and found the answer regarding the "cannot open display" issue. Problem is you can't have the root user connect to the X display in Ubuntu (with default settings), but we need to run our installer as root (fail-design). First install sux (switchuser with X credentials). Allow the root user to connect to X display. Get current display settings. Then use sux to switch to root user. Run installer with display settings. 1. sudo apt-get install sux 2. /usr/bin/xhost + 3. echo $DISPLAY (use this in step 5) 4. sudo sux - 5. DISPLAY=:0.0 ./AdobeAIRInstaller.bin
    – Nicholi
    Dec 12, 2013 at 0:15

Ubuntu 14.04 - 32 and 64 bit - easy .deb install

Because of the way that multiarch works, you can can now simply install the i386 .deb file on newer 64bit Ubuntu and it will automatically install the right dependencies. (Also the 64 bit .deb is just the 32bit repackaged with a dependency on ia32-libs)

  1. Download the 32 bit(yes even for your 64 bit Ubuntu) deb: http://update.devolo.com/linux/apt/pool/main/a/adobeair/adobeair_2.6.0.19170-devolo1_i386.deb (Thanks to yuvilio's answer) The 64 bit package on the same site is a repackaged version of the 32 bit, you will have problems if you use the 64 bit package instead, use the 32 bit package for both 32 and 64 bit systems Ubuntu 13.10+.

  2. Open in software center, click Install

    enter image description here Ignore the warning about package quality

Alternatively if you have a Steam game that requires Air, simply install and run that game and it will install Air on the first run of the game.

Example games that use Air:

  • Defenders Quest
  • Anodyne (gets confused if you already have Air installed, run sudo apt-get remove adobeair and try the game installer again since it comes with Air)

I found these during a Weekly Humble Sale to support some open source projects.

  • I'm running Kali Linux and wanted to install the devolo-dlan-cockpit package, which requires adobeair. For me this solution worked perfect.
    – Joey
    Oct 21, 2019 at 22:14

Step 1: Get some Air Next download the Adobe Air .bin file (direct link here).

Step 2: Installation

Open a terminal (applications > Accessories > Terminal) and navigate to your Downloads folder (or the folder in which you saved the .bin file).

* cd Download/

We need to let the .bin file have permissions to install so enter the following command carefully: -

* chmod +x AdobeAIRInstaller.bin

Now lets install it:

* ./AdobeAIRInstaller.bin

Installation should zip though and, if everything goes okay, a new menu entry will appear in ‘Applications > Accessories’ titled ‘Adobe Air Application Installer’.

  • 4
    This does not work on Ubuntu 13.10 x64 Feb 25, 2014 at 1:35

...finally after some trouble and after many searches on this forum, google and others pages have managed to do it. First I want to thank the community that gave me more ambition to do it, than make me quit to install AdobeAir.

Whole problem was the package ia32-libs(The ia32-libs package was a hack to get 32-bit packages installed on a 64-bit installation. Since Ubuntu version 11.10 (Oneiric), Multi Arch has been added. One of the objectives for it is removing the ia32-libs package)... package that Canonical has decided to end support for it.

All I had to do to install ia32-libs package was to add this repo:

1- ''deb http://archive.ubuntu.com/ubuntu/ raring main restricted universe multiversepackage source''

I followed the steps from this quick and easy tutorial:


2- then this page that leads me to this nice steps to install Adobe Air For 64-bit Systems


-----------------documentation that I used:---------------

www.askubuntu.com/questions/91815/how-to-install-software-or-upgrade-from-old-    unsupported-release  

P.S. ---as noted by Alvar, Adobe Air for Linux is no longer supported---

  • 2
    Check out this link. It worked well. tkalin.com/blog_posts/… Feb 2, 2014 at 4:49
  • @MichaelMikowski Your link helped me. The above links did not have a solution of manual coping library which could not be installed. After that, I got AdobeAir installed.
    – ubuntico
    Mar 7, 2014 at 8:46

Unfortunately, many years late "Adobe AIR for Linux is no longer supported." following what adobe page says. Using the "AIR archive" is possible to get unsupported versions, the 2.6.0 version is the most recent available. If you need to install a program that require a newer version of it, you might go to Virtual box with a Windows guest.

The recommend steps for Ubuntu 16.10:

for 32bit machine

wget -O adobe-air_i386.deb http://drive.noobslab.com/data/apps/AdobeAir/adobeair_2.6.0.2_i386.deb
sudo dpkg -i adobe-air_i386.deb
sudo apt-get install -f && rm adobe-air_i386.deb

for 64bit machine

wget -O adobe-air_amd64.deb http://drive.noobslab.com/data/apps/AdobeAir/adobeair_2.6.0.2_amd64.deb
sudo dpkg -i adobe-air_amd64.deb
sudo apt-get install -f && rm adobe-air_amd64.deb

The recommend steps for Ubuntu 16.04/14.04/12.04/Linux Mint 18/17/13 (both extracted from here):

wget -O adobe-air.sh http://drive.noobslab.com/data/apps/AdobeAir/adobe-air.sh
chmod +x adobe-air.sh;sudo ./adobe-air.sh

I have Ubuntu 14.04 64-bit. The only way of installing Adobe Air that worked for me was to follow the first part of these instructions for installing Balsamiq on Ubuntu, which is what I was trying to do in the first place.

A brief summary of those instructions: - Download this Adobe Air installer - Installing the 32-bit libgtk package (but I skipped this step; it didn't work for me, and didn't seem necessary) - Making symbolic links to two libgnome-keyring files - Making the Adobe Air installer executable and running it with sudo


On Ubuntu 18.04, this worked for me:

wget -O adobe-air_i386.deb http://drive.noobslab.com/data/apps/AdobeAir/adobeair_2.6.0.2_i386.deb
sudo dpkg -i adobe-air_i386.deb

Here it will throw an error saying that the package have unmet dependencies.

Run this and it should install what's needed:

apt --fix-broken install

If that doesn't work:

I've tried a few things before as well, and I'm not sure if that's necessary for it to work. I've had run: sudo apt-get install libbz2-1.0:i386 libgtk2.0-0:i386 libnss3:i386 libxaw7:i386

As a general tip, see if some error pops up when running sudo dpkg -i adobe-air_i386.deb and try to solve it by installing the necessary packages.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .