5

I'd like to disable the alt+rightclik keybinding as it is shared by Blender. All of the solutions so far have involved using ccsm, but so far, that hasn't worked for me. Does anybody know how to do this?

  • 1
    Welcome to Ask Ubuntu! ;-) Could you try gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier '' and report back? – Fabby Jan 21 '17 at 10:37
  • Thanks. That command completely messed up my mouse bindings though - I'm having to shift+leftclick for normal click. Leftclick turned into drag, and rightclick turned into window menu. How do I set it back please? – YoungPadawan Jan 21 '17 at 12:43
  • OK, with a bit of research, I found this command, which returned everything to normal: gsettingsreset org.gnome.desktop.wm.preferences mouse-button-modifier – YoungPadawan Jan 21 '17 at 16:15
  • Only back on-line now. '<alt>' was the original modifier. Setting it to anything other then that has worked as I can see! – Fabby Jan 21 '17 at 20:38
  • I used this method on ubuntu 16.04 askubuntu.com/a/521447/667618 to disable alt+rmb, because I would like to use in within blender to select edge loops! – Evgeny Bobkin Jan 22 '18 at 17:36
7

After a bit of research following Fabby's comment - I used the following command, which has worked:

gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier '<Super>'

Now it's the super key which brings up the window menu.

  • Thank you for your research. I did this and it worked for me as well, where Compiz could not change any Ubuntu 16 keybindings for some reason. – Georg Muehlenberg Jun 25 '18 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.