When trying to install SPSS (a statistical analysis package) using sudo ./SPSS_23.0_LNX.bin I get the following:

Preparing to install...    
Extracting the JRE from the installer archive...
Unpacking the JRE...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...
Launching installer...
JRE libraries are missing or not compatible....

OpenJDK 6, OpenJDK 7, Oracle Java 7, and Oracle Java 8 are all installed on my machine. I tried the install with each of them as default, successively ( I did set the JAVA_HOME environment to the appropriate path each time). Every time I got the the same output and error message.

It looks that the JRE is packaged in the installer, which would mean that there is something wrong with the libraries in the packaged JRE. Then there wouldn't be much I could do about it. Does that make sense?

  • What software? How have you installed Java?
    – user589808
    Jan 21 '17 at 0:31
  • Yes, I've tried the version of Java I mentioned above.
    – sapin
    Jan 21 '17 at 0:42
  • I found that installing these packages resolved this error for me: libmotif-dev lib32z1 libc6-i386 rpcbind xfonts-100dpi xfonts-75dpi ksh
    – pztrick
    Mar 15 '18 at 21:30

I found this solution and it works.

If you want the short version, just add this to the line after you type your installer. For me, I was installing a .bin package. I was using the line:

sudo ./INSTALLER.bin

Try this:

sudo ./INSTALLER.bin LAX_VM path_to_java_on_your_machine

So, for me, the entire command was:

sudo ./LiberoSoC_v11.8Linux.bin LAX_VM /usr/lib/jvm/java-8-oracle/jre/bin/java

I needed the sudo so the actual installer could write to /usr/local once it started.

To see what is going on with the LAX tool, set the environment variable LAX_DEBUG with

export LAX_DEBUG=true

Now you can see that the Lax_vm is trying to use the locally installed jre in /tmp, but for some reason that won't work on all linux platforms. By telling it you use the one installed on your system, you should at least get the installer to start. After that, you are on your own.


With Java based applications which do not come as a package from the software channels in Ubuntu, you will most likely have to define JAVA_HOME dir, because those apps will not know about the "default" java deb package. For example on the command line :

export JAVA_HOME="/usr/lib/jvm/java-1.8.0-openjdk-amd64"

The SPSS seems to be software made by IBM. With the command :

ldd -v  ./SPSS_23.0_LNX.bin

you should be able to see which libraries it wants to use.

Perhaps it wants to use IBM Java.

IBM Java


OpenJDK 6, OpenJDK 7, Oracle Java 7, and Oracle Java 8 are all installed...I did set the JAVA_HOME environment to the appropriate path each time

This happens when you're using a package that includes a bundled JRE and that JRE isn't compatible with your OS. A typical case is that the JRE was built on a 32-bit OS and you're running on a 64-bit-only host, with no 32-bit backwards compatibility. Another typical case is that the package was built for a different flavor of Linux and its paths to critical libraries like glibc differs from that on your flavor of Linux.

The simplest fix I found is to move that incompatible JRE out of the way so that your JAVA_HOME setting becomes effective:

$ export JAVA_HOME=/usr/lib/jre/java-1.8.0
$ mv bin broken-jvm
$ ./program-launcher

I'm writing the above generically because this solution isn't specific to SPSS. I discovered the above solution using a different Java-based software package that was giving the same symptom as the one posted here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.