7

I've installed Ubuntu Studio 16.04.1 LTS on my pc (ASRock X99 Taichi, i7 6800k, GTX 970, DisplayPort to iMac as monitor), my first experience with Ubuntu/Linux. I haven't installed any third party software during installation.

Whenever I play videos on youtube, the first 3-5 seconds are mute. If I pause and start playing the video from the beginning a second time, then the audio starts playing at the start. This happens every time I open a new video. Everything is in sync, but the audio always takes time to start playing. How can I fix this annoying glitch/delay? I am using the default Ubuntu Studio xfce desktop environment.

5
  • Have you tried to install Google Chrome to see if it does the same behaviour ? Jan 20, 2017 at 22:11
  • Oooh, not yet. I'm going to try now.
    – CPLTarun
    Jan 20, 2017 at 22:14
  • ok, try do that and see if it helps. :) Jan 20, 2017 at 22:15
  • Just tried with Chrome. Same exact thing, audio playback is delayed for 5 seconds :/
    – CPLTarun
    Jan 20, 2017 at 22:26
  • Can't remember this happening in over 4 years of using Ubuntu but it started happening about a month ago in both Youtube and Flashplayer where sound is delayed for a few seconds after video starts. May 20, 2018 at 0:38

2 Answers 2

8

Perfect solution for specific problem, but not all applications

This solution works when pausing and resuming from the same sound source such as a movie:

Edit Pulse Audio configuration file: sudo -H gedit /etc/pulse/default.pa

Locate this section and place # in front of second line:

### Automatically suspend sinks/sources that become idle for too long
# load-module module-suspend-on-idle

Save the file and exit.

Reload Pulse Audio using pulseaudio -k.

Where it doesn't work.

Whilst watching a movie I can have laundry timer running in the background. When a alert sounds to signal end of Wash Cycle, Rinse Cycle or Dryer no sound is heard. The alert sound was < 5 seconds. The workaround is to pick a different sound file > 5 seconds long.

1
  • This module can also be unloaded with pactl unload-module module-suspend-on-idle command. Dec 21, 2021 at 20:55
0

My sound would take anywhere from 5 seconds to a minute before it would come on. Only on Firefox and going to YouTube. I tried everything on every forum. What turned out to be the problem for me was Firefox had a security and privacy setting set to block all video and audio. I turned the setting to allow all video and audio. No more problems....so far.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.