0

I just installed Lubuntu 16.04 i686/i386 (alongside an existing Windows installation) on an HP Mini-110.

Since I needed additional drivers (broadcom) to get my wifi working, I installed those as well.

Now, the wireless adapter seems to be functioning correctly. I get the option to connect to available nearby networks. Although, I should mention the one want to connect to seems to keep dropping off the list (as well as certain others), while the rest stay on the list consistently. Also, my router has been very close to the netbook while I've tried to connect (maybe not more than 4ft away).

Now the problem is, whenever I click on my network and try to join, it asks me for the password, accepts it, displays the "connecting" animation on the wifi icon in the taskbar for some time, then asks for the password again even though I've checked remember password.

Wash, rinse, repeat.

I don't know what's happening or even how to begin addressing this issue. Maybe it's simply an issue with transmit power or interference? Any help would be greatly appreciated. Thanks!


Some useful information:

Modem/Router: Arris DG1670A, with spec sheet link on page.

Wireless interface:

description: Wireless interface
product: BCM4312 802.11b/g LP-PHY
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:01:00.0
logical name: wlp1s0
version: 01
serial: 90:4c:e5:70:1d:54
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=wl0 driverversion=6.30.223.248 (r487574) latency=0 multicast=yes wireless=IEEE 802.11abg
   resources: irq:16 memory:feafc000-feafffff

=====EDIT=====

The drivers listed in the answers given below are correct.

The only other issue I was having (connection speed and reliability) had more to do with the fact that there were several other access points close to mine. A better positioning of the netbook helped. I also configured the wireless card with the following command:

sudo iwconfig <interface-logical-name> rts 2347B

Here <interface-logical-name> is the logical name used for your wireless card. This can be found listed under "logical name" for your wireless interface if you run lshw -class network.

I chose 2347B since I already had another linux machine connected to my network which worked just fine. So I just ran iwconfig <interface-logical-name> to check the relevant parameters for the configuration on that machine. Although, I'm no expert on this, but educated (and relatively safe) guesses never hurt anyone :)

Of course, if you're new, feel free to take your time going through man iwconfig.

Also, as per chili555's suggestions in the edit to his answer, setting the REGDOMAIN and IPv6 method is helpful. And if you're up for it, changing the settings on your router would also be beneficial. Just be sure you know what you're doing as some kinds of devices may rely on the precise configuration of your router/modem and making a wrong change by mistake can get you into trouble.

2

This is a wrong driver. Connect to the internet by wire and run

sudo apt purge bcmwl-kernel-source
sudo apt install firmware-b43-installer
  • Thank you! This worked. I just had one more concern as I've mentioned in a comment to chili555's answer. The connection speed is really slow; maybe I should increase transmit power? I don't know too much about this and CRDA limits, heating, etc. Thanks again! – ThisIsNotAnId Jan 20 '17 at 22:16
  • I picked this as an answer because it was the first and right answer. – ThisIsNotAnId Jan 20 '17 at 22:20
  • I do not think the problem is with CRDA restrictions. – Pilot6 Jan 20 '17 at 22:23
  • What might be the problem? – ThisIsNotAnId Jan 20 '17 at 22:39
  • Sorry about the change, but the question is open again. Seems I need more than the right drivers. Please see the comments to chili555's answer. – ThisIsNotAnId Jan 23 '17 at 16:47
3

The Additional Drivers tool will happily offer to install the wrong driver! Please get a temporary internet connection by ethernet, tethered or whatever means possible. Let's remove the incorrect driver:

sudo apt-get purge bcmwl-kernel-source

And next, let's install the firmware required to get the correct drivers b43 and bcma, working:

sudo apt-get install firmware-b43-installer

Reboot and your wireless should be working correctly.

PS- @Pilot6 is too fast!!!

First, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/images/netconfig/network-connections-ipv6-ignore.png This example is for ethernet, but you want wireless.

  • Thanks! It worked. But the connection is archaically slow. Like 5kb/s. Any pointers? I want to say transmit power but I'm a noob :) – ThisIsNotAnId Jan 20 '17 at 22:17
  • I'm also concerned about CRDA limits and heating, etc. Thanks! – ThisIsNotAnId Jan 20 '17 at 22:19
  • I will edit my answer to give a few pointers in a few moments. Glad it's working. – chili555 Jan 20 '17 at 22:43
  • Thanks for the new info. I would love to try it out, however, it would seem I'm still having issues with the nic picking up the desired network. It just doesn't even show up sometimes. I did some searching and found that broadcom has their own linux drivers on their website which I would like to try. Although I'm not sure if the one's they have would be compatible with my i686 architecture. Alternatively, I was also thinking I could just use the Ndiswrapper for windows drivers, but, again, don't have any idea how I might set that up. – ThisIsNotAnId Jan 23 '17 at 16:41
  • I'm also trying to avoid changing settings on my router as we have a delicate setup. – ThisIsNotAnId Jan 23 '17 at 16:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.