1

This is a very consistent problem to recreate. Every odd-numbered reboot or restart results in a working wi-fi connection, failing for even numbers.

HP Laptop 15-g018dx with fresh Ubuntu desktop install and upgrades/updates.

Version:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.1 LTS
Release:    16.04
Codename:   xenial

Adapter:

$ lspci -vvnn | grep Network
03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter [10ec:8179] (rev 01)
Subsystem: Hewlett-Packard Company RTL8188EE Wireless Network Adapter [103c:197d]

NetworkManager status when it's working:

$ sudo service NetworkManager status
NetworkManager.service - Network Manager
 Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
 Active: active (running) since Thu 2017-01-19 18:39:51 PST; 7min ago
 Main PID: 940 (NetworkManager)
 CGroup: /system.slice/NetworkManager.service
 ├─ 940 /usr/sbin/NetworkManager --no-daemon
 ├─1142 /sbin/dhclient -d -q -sf /usr/lib/NetworkManager/nm-dhcp-helper -pf /var/run/dhclient-wlo1.pid -lf /var/lib/NetworkManager/dhclient-ead33c49-08dd-4240-ae63-1edec65394f6-wlo1.lease -cf /var/lib/NetworkManager/dhclient-wlo1.conf wlo1
 └─1154 /usr/sbin/dnsmasq --no-resolv --keep-in-foreground --no-hosts --bind-interfaces --pid-file=/var/run/NetworkManager/dnsmasq.pid --listen-address=127.0.1.1 --cache-size=0 --conf-file=/dev/null --proxy-dnssec --enable-dbus=org.freedesktop.NetworkManager.dnsmasq --conf-dir=/etc/NetworkManager/dnsmasq.d
dhclient[1318]: XMT: Info-Request on wlo1, interval 940ms.
dhclient[1318]: RCV: Reply message on wlo1 from fe80::a62b:8cff:fed2:ab22.
NetworkManager[940]: <info>  nameserver '2001:578:3f::30'
NetworkManager[940]: <info>  nameserver '2001:578:3f:1::30'
NetworkManager[940]: <info>  dhcp6 (wlo1): state changed unknown -> bound
NetworkManager[940]: <info>  dhcp6 (wlo1): client pid 1318 exited with status 0
NetworkManager[940]: <info>  dhcp6 (wlo1): state changed bound -> done
NetworkManager[940]: <info>  WiFi hardware radio set enabled
NetworkManager[940]: <info>  WWAN hardware radio set enabled
NetworkManager[940]: <info>  manager: startup complete

NetworkManager status when it's not working:

$ sudo service NetworkManager status
NetworkManager.service - Network Manager
 Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
 Active: active (running) since Thu 2017-01-19 18:49:12 PST; 1min 6s ago
 Main PID: 917 (NetworkManager)
 CGroup: /system.slice/NetworkManager.service
 └─917 /usr/sbin/NetworkManager --no-daemon
NetworkManager[917]: <warn>  failed to enumerate oFono devices: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.ofono was not provided by any .service files
NetworkManager[917]: <info>  ModemManager available in the bus
NetworkManager[917]: <info>  supplicant: wpa_supplicant running
NetworkManager[917]: <info>  device (wlo1): supplicant interface state: init -> starting
NetworkManager[917]: <info>  device (wlo1): supplicant interface state: starting -> ready
NetworkManager[917]: <info>  device (wlo1): state change: unavailable -> disconnected (reason 'supplicant-available') [20 30 42]
NetworkManager[917]: <info>  device (wlo1): supplicant interface state: ready -> inactive
NetworkManager[917]: <info>  manager: startup complete
NetworkManager[917]: <info>  WiFi hardware radio set enabled
NetworkManager[917]: <info>  WWAN hardware radio set enabled

And finally, Syslog when good (and common lines when bad are marked with an asterisk below:

* kernel: rtl8188ee 0000:03:00.0 wlo1: renamed from wlan0
* NetworkManager: <info>  devices added (path: /sys/devices/pci0000:00/0000:00:02.4/0000:03:00.0/net/wlo1, iface: wlo1)
* NetworkManager: <info>  device added (path: /sys/devices/pci0000:00/0000:00:02.4/0000:03:00.0/net/wlo1, iface: wlo1): no ifupdown configuration found.
* NetworkManager: <info>  (wlo1): using nl80211 for WiFi device control
* NetworkManager: <info>  device (wlo1): driver supports Access Point (AP) mode
* NetworkManager: <info>  manager: (wlo1): new 802.11 WiFi device (/org/freedesktop/NetworkManager/Devices/2)
* NetworkManager: <info>  device (wlo1): state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
* kernel: IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
* kernel: IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
* NetworkManager: <info>  device (wlo1): supplicant interface state: init -> starting
* NetworkManager: <info>  device (wlo1): supplicant interface state: starting -> ready
* NetworkManager: <info>  device (wlo1): state change: unavailable -> disconnected (reason 'supplicant-available') [20 30 42]
* kernel: IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
* NetworkManager: <info>  device (wlo1): supplicant interface state: ready -> inactive
NetworkManager: <info>  device (wlo1): Activation: starting connection 'My-Wi-Fi' (ead33c49-08dd-4240-ae63-1edec65394f6)
NetworkManager: <info>  device (wlo1): state change: disconnected -> prepare (reason 'none') [30 40 0]
NetworkManager: <info>  device (wlo1): state change: prepare -> config (reason 'none') [40 50 0]
NetworkManager: <info>  device (wlo1): Activation: (wifi) access point 'My-Wi-Fi' has security, but secrets are required.
NetworkManager: <info>  device (wlo1): state change: config -> need-auth (reason 'none') [50 60 0]
NetworkManager: <info>  device (wlo1): state change: need-auth -> prepare (reason 'none') [60 40 0]
NetworkManager: <info>  device (wlo1): state change: prepare -> config (reason 'none') [40 50 0]
NetworkManager: <info>  device (wlo1): Activation: (wifi) connection 'My-Wi-Fi' has security, and secrets exist.  No new secrets needed.
NetworkManager: <info>  sup-iface[0x248fa10,wlo1]: config: set interface ap_scan to 1
wpa_supplicant: wlo1: SME: Trying to authenticate with a4:2b:8c:d2:ab:23 (SSID='My-Wi-Fi' freq=2462 MHz)
kernel: wlo1: authenticate with a4:2b:8c:d2:ab:23
NetworkManager: <info>  device (wlo1): supplicant interface state: inactive -> authenticating
wpa_supplicant: wlo1: Trying to associate with a4:2b:8c:d2:ab:23 (SSID='My-Wi-Fi' freq=2462 MHz)
kernel: wlo1: send auth to a4:2b:8c:d2:ab:23 (try 1/3)
kernel: wlo1: authenticated

On those boots when it's not working, doing a sudo /etc/init.d/network-manager stop and then ...start does not fix things.

When it's bad, no wi-fi zones show up in the panel app. It thinks both networking and wi-fi are enabled in that panel. Toggling the keyboard wi-fi doesn't help.

I won't add to this the analysis of good->suspend->re-awaken since this post is already so long.

Any thoughts? I considered dropping a link into maybe /etc/rc6.d perhaps but I'm a bit of a noob to attempt that myself.

6
  • How did you come to the conclusion of even and odd booting times as I have the same problem and have resigned it to be occasional hardware failure as my Hp didn't originally come with Ubuntu... – George Udosen Jan 20 '17 at 21:08
  • 1
    It was arbitrary. Some people aren't familiar with the term "every other" so I just wrote it that way. For me, it's exactly every other boot for success/failure rather than an intermittent problem. (And the log for the wi-fi router does not show any attempt on the fails, for what it's worth.) – Justin Case Jan 20 '17 at 21:20
  • Yes I noticed that too about the logs lacking any reasonable information to work with. – George Udosen Jan 20 '17 at 21:23
  • Purchased HP with Win 7, upgraded to Win 10. This last November after an update it got stupid and you could surf the Internet (ethernet or wi-fi) and yet the Metro side of Windows thought you weren't connected to the Internet, making all Metro apps fail. So this is me with a fresh install of Ubuntu after a disk wipe. – Justin Case Jan 20 '17 at 21:26
  • Mine was from Win 8.1 but I think for me its a module load issue ( I think) but can't figure out which... – George Udosen Jan 20 '17 at 21:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.