2

I created /boot and / and swap upon install. I allowed Ubuntu to partition it for me. I did not do any manual partitioning.

I ran into problems on this install, in getting it to boot. They were solved by:

mount /dev/sda1 /mnt 
cd /mnt/EFI 
mkdir -p Microsoft/Boot
cp /mnt/EFI/ubuntu/grubx64.efi /mnt/EFI/Microsoft/Boot/bootmfgw.efi
efibootmgr -c -L "Windows Boot Manager" -l " \EFI\ubuntu\shimx64.efi"
efibootmgr -c -L "Windows Boot Manager" -l "
\EFI\Microsoft\Boot\bootmfgw.efi "

and this fixed and I could boot.

Since then, I started ripping out lightdm, NetworkManager, and a number of services I just didn't need. Then i remembered "tasksel". And this is where I got in trouble.

I installed tasksel... I unselected the Ubuntu Desktop, selected the SSH Server and Samba Server (as i already had them installed)... and tasksel just went off uninstalling damned near everything. It removed my ntfs drivers, it removed vim, I saw "grub" packages being removed. I'm not really sure what's gone and what stayed.

But when I rebooted it obviously doesn't come up.

I get an error that states

vmlinux-4.8.0-32-generic.efi.signed not found

I'd really prefer not to reinstall b/c i have a TON of infromation that lives outside of my home directory that I would have to backup (again..just ot make sure) and then restore. And I'm really hoping to avoid that.

Any help is greatly appreciated.

  • FWIW, I too used tasksel to remove Ubuntu Desktop, and now cannot boot with a similar error. /boot/vmlinuz-…-96 exists, but not /boot/vmlinuz-…-96.efi.signed which is what it is looking for. – Phrogz Oct 2 '17 at 21:50
  • I thought removing Ubuntu Desktop after installing Ubuntu Desktop Gnome via tasksel would just remove Unity. Nope :( – Robert Dundon Mar 29 '18 at 2:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.