I recently tried installing libusb(and failing) using the following:
sudo apt-get install libusb-1.0-0-dev
as mentioned on the askUbuntu. But I got errors saying following packages couldn't be installed: libusb-1.0-0-dev: libusb-1.0-0-dev (2:1.0.21-1) will be installed (note- I don't remember the exact error since I moved on and installed it using cmake by downloading the .tar file)
So I changed the command accordingly but still in vain. Due to the persistent error I installed the package from the Ubuntu repository. Details of the package I downloaded:
amd64 53.4 kB 281.0 kB [list of files]
Now I am trying to use Mircosoft Kinect V2 for SLAM through libfreenect2 on Ubuntu 14.04 and ROS Indigo and getting an error:
[Error] [Freenect2Impl] Your libusb does not support large iso buffer! no device connected!
dpkg -l libusb-1.0*
The output I received detailed that the version number is 1.0.17 however the latest is available online is 1.0.21
||/ Name Version Architecture Description +++-=============================-===================-===================-=============================================================== ii libusb-1.0-0:amd64 2:1.0.17-1ubuntu2 amd64 userspace USB programming library ii libusb-1.0-0-dev:amd64 2:1.0.17-1ubuntu2 amd64 userspace USB programming library development files ii libusb-1.0-doc 2:1.0.17-1ubuntu2 all
It makes perfect sense because I downloaded the 1.0.17 version. Now how can I update libusb 1.0.17 to 1.0.20.
I have already tried the following commands as mentioned on askUbuntu question:
sudo apt-get --only-upgrade install libusb-1.0-0-dev sudo apt-get install libusb-1.0-0-dev
but not of much use. The version of libusb is still 1.0.17. Kindly suggest another method to update it to 1.0.20. In case you recommend deleting the existing version and reinstalling the new version 1.0.20 then kindly outline the steps to delete the libusb 1.0.17 (keep in mind that I installed it using make).
[EDIT - Ubuntu 14.04] and I cannot upgrade to 16.04 since the packages that I need to work with are compatible with 14.04 only