1

I found that on two freshly installed Ubuntu 16.04-LTS desktops, for some reason I can't perform reboot or shutdown. I click on reboot/shutdown in the upper right corner's popup dialog but nothing happens when I chose reboot or shutdown option. It is OK when I do the same in terminal window by issuing shutdown or reboot command.

  • does sudo init 0 work? – Nisheet Jan 20 '17 at 12:33
  • yes, moreover: when I click on Shutdown or Reboot on my desktop then foloowing message appears in the syslog: pastebin.com/EGvXCRsD – Syn Romana Jan 23 '17 at 9:36
  • Might be a kernel issue, as stated in the bug here. Try with the latest kernel if it fixes the issue. – Nisheet Jan 23 '17 at 10:52
  • Some users have fixed it be editing /etc/default/grub line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force" then run sudo update-grub Source – Nisheet Jan 23 '17 at 10:55
  • GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force" doesn't work for me. – Syn Romana Jan 23 '17 at 11:53
0

I had the same problem, hard shut-off your computer (Holding the power button down for 10-20 seconds) and turn it on again. Not the most graceful way, but it works.
Hope this helps!!

  • How will this fix the problem that reboot/shutdown dialog doesn't worg ? On top you will risk having to do fsck on your filesystems at next boot and potentially loose data ! – Soren A Jan 20 '17 at 12:34
  • It worked for me, I don't know why but it was very glitchy when I first got ubuntu. – Ubuntu User Jan 20 '17 at 12:52
0

OK, finally I found the problem. The problem was with PAM configuration files modified during installation (from local preseed) process.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.