8

I have both windows 10 and ubuntu 16 installed on my system.

Lately the system is automatically booting to windows. To boot to ubuntu, I first have to pause startup by pressing escape and then boot into ubuntu.

I know that I have to change the boot order to Ubuntu but am not able to do so and the grub customiser helps to change only the boot order in grub menu to the best of my knowledge.

What should I do? I am unable to find any way to change the boot order in bios

16
  • What is the make and model number of your computer? Jan 20 '17 at 11:13
  • It is HP Envy series
    – humble
    Jan 20 '17 at 11:14
  • Could you provide the /etc/default/grub content to your question? Jan 20 '17 at 11:19
  • HP has a number of Envy series computers. They even have printers with the same name stamp. Can you check your computer for more details such as the model number? I see a number of desktops and Laptops, but would like to minimize time by going to your specific model. Jan 20 '17 at 11:20
  • 1
    @L.D. James Thanks a lot....It worked....Please post the above aa answer so that I may accept it as the correct answer
    – humble
    Jan 20 '17 at 12:30
5

The problem can be resolved by going into the

BIOS -> UEFI Boot Order > OS Boot Manager

The exact wording will vary on different computer makes and models.

Now look for the Ubuntu entry. Select that one and save the settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.