3

I have installed Ubuntu several times on my old notebook and everything always worked fine. Now I have a new one:

  • Schenker H507 (CLEVO P65-67RSRP) with G-Sync Display
  • Intel Core i7 6700HQ
  • Intel HD 530
  • NVIDIA GTX 1070
  • Crucial Balistix Sport 32GB DDR4 2400Mhz RAM

On this Notebook I have a SAMSUNG 960 Pro SSD with Windows 10 running in UEFI mode.
Now I wanted to install Ubuntu Desktop 16.04.1 LTS on my second SSD (SAMSUNG 850 Pro).

My Problem is that only if I turn on Discrete Mode in BIOS, which is for exclusively using the NVIDIA GTX 1070 graphics and shutting off Intel HD 530, I can boot into Ubuntu and install it.

Here is a picture taken after installation in UEFI mode with only discrete graphics activated.

I already tried many several solutions provided on Ask Ubuntu, but they all did not work for me. With HD 530 activated either I got a black screen or stuck at loading screen or a flickering screen.

I can install Ubuntu in Legacy Mode with both graphics cards activated, but I can not convert Ubuntu Legacy into UEFI mode.

lshw output of display in Legacy Mode:

*-display UNCLAIMED
                description: VGA compatible controller
                product: NVIDIA Corporation
                vendor: NVIDIA Corporation
                physical id: 0
                bus info: pci@0000:01:00.0
                version: a1
                width: 64 bits
                clock: 33MHz
                capabilities: vga_controller bus_master cap_list
                configuration: latency=0
                resources: memory:db000000-dbffffff memory:90000000-9fffffff memory:a0000000-a1ffffff ioport:e000(size=128) memory:dc000000-dc07ffff

*-display
             description: VGA compatible controller
             product: Intel Corporation
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 06
             width: 64 bits
             clock: 33MHz
             capabilities: vga_controller bus_master cap_list rom
             configuration: driver=i915_bpo latency=0
             resources: iomemory:2f0-2ef irq:127 memory:2ffe000000-2ffeffffff memory:80000000-8fffffff ioport:f000(size=64)

Can someone help me please? I also tried Ubuntu 16.10. Currently I have Ubuntu installed in UEFI mode with only GTX 1070 activated. I do not want to turn off HD 530 every time I boot Ubuntu.

  • My Skylake system is Intel only but I installed this: 01.org/linuxgraphics/intel-linux-graphics-firmwares but I still get message on possible missing kbl version which is just for Kabylake. the dmc file was same version as I already had, but I installed skl/GuC version. – oldfred Jan 20 '17 at 14:49
  • i tried to install this and activate my Intel again but it did not work – Axel5192 Jan 20 '17 at 14:51
  • Generally it should work using this solution -> askubuntu.com/questions/871978/… ! Alternatively set the boot parameter nomodeset instead of nouveau.modeset=0 ... in case that you are facing the other errors (beside the nouveau error) shown in your screenshot ! :) – cl-netbox Jan 20 '17 at 15:43
  • should I install ubuntu with these tags or try to boot my already installed ubuntu with these? Should I install the nvidia drivers? They keep saying 16.10 version of ubuntu, should I use this? – Axel5192 Jan 20 '17 at 15:46
  • No matter which of the both flags i add at the end of the Linux line (without changing anything else) I just get a purple screen After pressing F10. But when I press the on/off Button my notebook shuts down with the ubuntu loading Icon – Axel5192 Jan 20 '17 at 15:52
3

Thanks to @cl-netbox I got the solution. If you already have Ubuntu installed in Discrete mode do this:

Open a Terminal and use this command:

sudo nano /etc/default/grub

put between this:

GRUB_CMDLINE_LINUX_DEFAULT="[...]

and this:

GRUB_CMDLINE_LINUX=""

the following:

GRUB_GFXPAYLOAD_LINUX=1920*1080

Save it with Ctrl+O and exit STRG+X. Then:

sudo update-grub

if its on the PC then open

sudo nano /etc/lightdm/lightdm.conf.d/50-dpms.conf

Put in front of each row a "#" Save it with Ctrl+O and exit STRG+X. Then try to reboot in DISCRETE again if every thing works. MSHYBRID Should now work.

How to use MSHYBRID in the Installer:

If you want to have it right in Install working the use MSHYBRID, to boot to >the Ubuntu USB. Highlight "Install Ubuntu" and press "E" One Row above "Linux /casper...." put

set gfxpayload=1920*1080

and start installation with F10. After Install use "Crtl+ALT+F1" to go to Terminal log in. Do the above steps to enable Booting in MSHYBRID mode.

source: https://www.linux-onlineshop.de/forum/index.php?page=Thread&threadID=385

Otherwise if you have a Clevo Notebook install Ubuntu in Discrete Mode like this: https://www.tuxedocomputers.com/TUXEDO-WebFAI.geek And then do the above steps.

  • Yeah right... pff! – userDepth Jan 20 '17 at 19:38
  • Only GRUB_GFXPAYLOAD_LINUX=1920*1080 was required for Ubuntu 17.10 (50-dpms.conf file is empty). Why is it needed at all, and what we should fix to make it work out of the box? – chfast Dec 10 '17 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.