1

I'm trying to dual-boot Ubuntu 16.04.1 alongside Windows 10 (with UEFI). I've tried and failed three times, and I'm not too sure what I'm doing wrong.

The problem I'm having is that after successfully installing Ubuntu and restarting my laptop, the Grub menu still gives me the same options that I had before: Install Ubuntu, Try Ubuntu without installing, etc.

Here are the steps I've taken:

  1. Partition 100GB of unallocated space on my hard drive with the built-in Disk Management tool
  2. Download Ubuntu and create a quickboot USB using Rufus
  3. Disable Windows Fastboot via the UEFI menu
  4. Select the quickboot USB as the first startup selection. The grub menu appears now when I restart my laptop. From there, I select the "Install Ubuntu" option. At this point, I am at the Ubuntu installation menu.
  5. I connect to the internet and select the options "Download updates while installing Ubuntu" and "Install third-party software for graphics and Wi-Fi hardware, Flash, MP3, and other media".
  6. On the "Installation type" menu, I choose the "Something else" option so that I can create a swap, home, and root partition.
  7. In the "Something else" menu, where I can view partitions (not my screenshot), using the 100GB of unallocated space I partitioned earlier in Windows, I first create a new partition of size 16GB for use as swap space. The options I use for this partition are

    • Size: 16384MB (16GB)
    • Type for the new partition: Primary
    • Location for the new partition: Beginning of this space
    • Use as: swap area
  8. Then I create a partition from the same unallocated space for the root file system. I use the following options:
    • Size: 71680MB (70GB)
    • Type for the new partition: Logical
    • Location for the new partition: Beginning of this space
    • Use as: Ext4 journaling file system
    • Mount point: /
  9. Finally, using the same unallocated space, I create another partition for /home. I use the following options:

    • Size: 10240MB (10GB)
    • Type for the new partition: Logical
    • Location for this partition: Beginning of this space
    • Use as: Ext4 journaling file system
    • Mount point: /home
    • When I am done making partitions, in the "Installation type" menu, under the "Device for boot loader installation:" option, I have selected /dev/sda [hard drive name]
  10. I then press "Install Now", which gives me a prompt saying that it will use the three partitions that I created. I click OK and it starts installing Ubuntu

  11. Ubuntu installs successfully and prompts me that I need to restart my laptop. I click OK and my laptop restarts. The Grub menu appears, but my options are the same as before I installed Ubuntu:

    • Install Ubuntu
    • Try Ubuntu without installing
    • Scan hard drive for errors [One other option here that I can't remember, but I know it does not have any relevance to the situation]

I've tried changing the first startup selection in the UEFI menu back to Hard Disk (windows boot), but that just goes straight to Windows 10.

Does anyone know what I'm doing wrong?

Sorry for the long post -- I wanted to make sure that I provided any and all helpful information. Let me know if there's any other information needed.

Thanks.

  • 2
    Have you tried removing the installation media? Ubuntu also does have a prompt for that. – mikewhatever Jan 20 '17 at 6:32
  • i guess @JGut forget to remove the USB-installation media – ryanw Jan 20 '17 at 6:49
  • @mikewhatever ryanw Thanks for the quick replies. I'm note sure I understand. Remove the USB after installation? Or remove certain files on the USB? I don't remember seeing any sort of prompt for removing installation media. – JGut Jan 20 '17 at 7:03
  • maybe you forgot for unplug your usb drive that used for installation Ubuntu. just unplug and reboot. and then see what's happen? – ryanw Jan 20 '17 at 7:16
3

After successful installation of the Ubuntu, unplug the USB drive that you used for installation. Reboot your system and then see what happens.

Right now I only understand that your USB is bootable, and that is why your system again accesses the same process and you get the same options that you had before: Install Ubuntu, Try Ubuntu without installing, etc.

  • 1
    Yeah i think this might be the problem. It's especially common with virtual machines. – Mustafa Yılmaz Jan 20 '17 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.