0

The output of lspci -knn | grep Net -A2

03:00.0 Network controller [0280]: MEDIATEK Corp. MT7630e 802.11bgn Wireless Network Adapter [14c3:7630]
    Subsystem: Foxconn International, Inc. MT7630e 802.11bgn Wireless Network Adapter [105b:e074]
    Kernel driver in use: mt7630e
    Kernel modules: wl, mt7630e

and the output of iwconfig

    lo        no wireless extensions.

    wlp3s0f0  IEEE 802.11bgn  ESSID:"d51085108"  
              Mode:Managed  Frequency:2.452 GHz  Access Point: 10:FE:ED:EC:B6:4A   
              Bit Rate=150 Mb/s   Tx-Power=20 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=70/70  Signal level=41 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:318  Invalid misc:1853   Missed beacon:0

    enp2s0f1  no wireless extensions.

I had installed the MT7630e driver, a few days ago I could still see the wifi under the wire connection but I got a error such as fail to connect.Now it displays device can't manage.

I had tried several suggestions before.

Add the output of ifconfig

enp2s0f1  Link encap:Ethernet  HWaddr 78:24:af:74:17:e4  
          inet addr:192.168.0.105  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::fd69:3920:2812:4052/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:68 errors:0 dropped:0 overruns:0 frame:0
          TX packets:88 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8489 (8.4 KB)  TX bytes:11254 (11.2 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:365 errors:0 dropped:0 overruns:0 frame:0
          TX packets:365 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:30507 (30.5 KB)  TX bytes:30507 (30.5 KB)

wlp3s0f0  Link encap:Ethernet  HWaddr 90:48:9a:d7:2d:59  
          inet addr:192.168.0.104  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::9248:9aff:fed7:2d59/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7058 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4710 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7698547 (7.6 MB)  TX bytes:830134 (830.1 KB)

and the output of ping -c3 www.ubuntu.com

PING www.ubuntu.com (91.189.89.115) 56(84) bytes of data.
64 bytes from www-ubuntu-com.privet.canonical.com (91.189.89.115): icmp_seq=1 ttl=46 time=270 ms
64 bytes from www-ubuntu-com.privet.canonical.com (91.189.89.115): icmp_seq=2 ttl=46 time=269 ms
64 bytes from www-ubuntu-com.privet.canonical.com (91.189.89.115): icmp_seq=3 ttl=46 time=270 ms

--- www.ubuntu.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2000ms
rtt min/avg/max/mdev = 269.768/270.210/270.682/0.707 ms

This was the output after I detach the ethernet, reboot and repeated the tests.

PING www.ubuntu.com (91.189.89.115) 56(84) bytes of data.
64 bytes from www-ubuntu-com.privet.canonical.com (91.189.89.115): icmp_seq=1 ttl=48 time=306 ms
64 bytes from www-ubuntu-com.privet.canonical.com (91.189.89.115): icmp_seq=2 ttl=48 time=306 ms
64 bytes from www-ubuntu-com.privet.canonical.com (91.189.89.115): icmp_seq=3 ttl=48 time=307 ms

--- www.ubuntu.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 306.443/306.948/307.782/0.746 ms

I don't get it, the system interface on the right top shows that I am not connect to neither ethernet or wifi but now I am edit my post.

I had added these lines in /etc/network/interfaces before I returned the file to default state, maybe I should add these back?

auto wlp3s0f0
iface wlp3s0f0 inet dhcp
    wpa-ssid SSID
    wpa-psk PASSWORD

Reboot with ethernet detached, Network Manager show that I have wifi but I am not truly connected, Chrome says I don't have connection.

$ lsmod | grep mt76

mt7630e               180224  0
mt76xx                 20480  0
mac80211              737280  1 mt7630e
cfg80211              565248  2 mac80211,mt7630e
eeprom_93cx6           16384  1 mt7630e
crc_ccitt              16384  1 mt7630e


$ rfkill list all

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: asus-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

$ ping -c3 www.ubuntu.com

ping: bad number of packets to transmit.
  • I would suggest that you remove the incorrect Broadcom driver: sudo apt-get purge bcmwl-kernel-source. Beyond that, it appears that you are well and truly connected to your network d51085108 Do you have an IP address? ifconfig? Can you surf the internet? How about: ping -c3 www.ubuntu.com? – chili555 Jan 20 '17 at 16:45
  • Added the outputs. And yes, I using the internet through the wire connection not the wireless connection. – Franlio Jan 21 '17 at 3:29
  • I also tried the sudo apt-get purge bcmwl-kernel-source command – Franlio Jan 21 '17 at 7:15
  • It is not at all useful to test your connectivity with the ethernet connected; obviously, you are connected. Please detach the ethernet, reboot and repeat the tests. – chili555 Jan 21 '17 at 15:32
  • OK. I tried as you suggest. – Franlio Jan 22 '17 at 3:10
1

the system interface on the right top shows that I am not connect to neither thernet or wifi

Please check the settings in Network Manager and elsewhere that determine if NM will manage your wireless interface.

gksudo gedit /etc/NetworkManager/NetworkManager.conf 

Use nano or kate or leafpad if you don't have the text editor gedit. Make certain that the file includes:

managed=false

If it says otherwise, change it, proofread carefully, save and close the text editor.

Also:

sudo gedit /etc/network/interfaces

Return the file to its default state:

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

If you made any changes, proofread carefully, save and close the text editor.

Restart NM:

sudo service network-manager restart

Is there any improvement?

  • managed=false is include, and as soon as I returned the interfaces file to the default state then restarted network manager I lose connection, I am using ethernet now. I had edited my post. – Franlio Jan 23 '17 at 4:16
  • If you remove the wlp3s0f0 lines from /etc/network/interfaces and restart NM or reboot, do networks now appear in the NM icon at the top right? Do you see yours? Are you challenged for the password when you select yours? – chili555 Jan 23 '17 at 14:23
  • No. It still shows that I don't have any internet connection. – Franlio Jan 24 '17 at 4:24
  • If you reboot with the ethernet detached, does the Network Manager icon show networks? Did the correct driver load? lsmod | grep mt76 Is the wireless turned off by the switch? rfkill list all Again, still with the ethernet detached, are you actually connected, although NM says not? ping -c3 www.ubuntu.com – chili555 Jan 24 '17 at 13:47
  • After I reboot with ethernet detached, the Network Manager icon still not show the network. I added some outputs in the post. – Franlio Jan 25 '17 at 13:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.