5

I have been facing the terrible problem to get to my Ubuntu desktop. I posted several questions and got several suggestions. To keep the track let me write down all the process I have been through: To start with, I have a MSI gaming laptop: Intel(R) Core i7-6820HK CPU 2.7GHz, 16GB RAM, Windows 10, 64x, NVIDIA GeForce GTX 980M.

About two weeks ago I installed Ubuntu 16.04 as a dual-boot together with Win 10. The obstacles I had during the installation were:

  1. There was a blank-purple screen: to solve it I set nomodeset and went on...

  2. There was no option "install Ubuntu alongside windows 10", I chose something else following the suggestions from this site...

  3. It directed me to partition the disks. There was no windows loader in the box, but only some values such as:

    free space 1 MB;
    /dev/sda1/ntfs with the 528345 MB 87947 MB used;
    /dev/sda2/ntfs with the 429495 MB 150 MB used;
    free space 1 MB;
    /dev/sda3 with the 21474 MB unknown;
    free space 0 MB;
    /dev/sda4 ntfs with the 20885 20100 MB used;
    free space 0 MB.
    

    However, I had already partitioned two disk spaces (30GB and 400GB) in Windows using disk partitioning...

  4. Then I deleted these two:

    /dev/sda4 ntfs with the 20885 20100 MB used
    /dev/sda3 with the 21474 MB unknown 
    

    to free some space for SWAP, root and boot and home (Mount point). I assigned appropriate sizes for respective mount points, again followed advice from Ask Ubuntu here. They are as follows:

     /dev/sda3 swap 2047 MB unknown
     /dev/sda4 ext4 /home 10240 MB unknown
     /dev/sda5 ext4 / 20479 MB unknown
     /dev/sda6 biosgrub 5 MB  unknown      
    

    At that stage I confirmed from this forum that I could proceed with the installation.

  5. After some time, I installed Cuda 8.0.44 and cuDNN v5.1 Library for Linux to learn Tensorflow with GPU support. To install Sublimetext I followed Youtube and I installed synaptic package manager and reloaded it as shown. The Reload failed. I thought rebooting might help and restarted the device, since then I couldn't log in to my desktop. I tried several ways to solve the issue such as this and this from Youtube

Side notes:

- there used to be a quick Nvidia window for, say, a millisecond when I switched it on. After installing Cuda 8.0.44 and cuDNN v5.1 that prompt disappeared;
- The laptop functioned strangely, it got shut down with a strange crack noise since I had dual-booted it with Ubuntu.
  1. After trying several solutions given in the forums, I ended up installing Gnome as suggested here as Solution 3. After rebooting, the desktop changed to Ubuntu Gnome, but still didn't solve the loop problem. Then I went to BIOS and changed the boot priority to another option, didn't work, then again came back to previous priority and now I can't even access to that login screen. When I switch the computer on I have purple screen suggesting *Ubuntu, Advanced options for Ubuntu, and System setup. Once I hit Ubuntu it goes through some process: screen Then the screen gets dark for about 4 seconds and quickly shows up this: screen Then it goes immediately back to dark screen and again after about 4 seconds the latter screen is shown again. This repeats infinitely.

When I type something, I can see them written after voodoo-GT80S 6QE login: but I can write ONLY AND ONLY when it is shown. If I use Ctrl + alt + f1, I can type for a short time, then it gets dark again. When I hit the power off, it shows:

     Starting WPA supplicant
     OK
     Started WPA supplicant. 

Then it is switched off with strange noise- like a rupture.

To solve the problem I tried this, given as Run These Commands

     1:  $ sudo mount /dev/sda5 /mnt
     2:  $ for i in /sys /proc /run /dev; do sudo mount --bind "$i" "/mnt/$i"; done
     3:  $ sudo mount /dev/sda6 /mnt/boot/efi
     5:  $ sudo chroot /mnt
     6:  # grub-install /dev/sda
     7:  # update-grub
     8:  # exit
     9:  $ for i in /sys /proc /run /dev; do sudo umount "/mnt/$i"; done
     10:  $ sudo umount /mnt/boot/efi
     11:  $ exit

When I typed sudo mount /dev/sda6 /mnt/boot/efi it is showing mount: mount point /mnt/boot/efi doesn't exist Please take into consideration that I am not able to directly write these code blocks to normal terminal because of flickering effect of the terminal. I am writing these things after forcing the terminal to show up every time by pressing ctrl+alt+f1.

I would ask you professionals to look through the problem and give some advice what to do next to restore the Ubuntu!

Thank you for your time and patience!

...this is for the question in the comments

  • Why don't you post a comment/feedback to this Link where you get stuck with the steps. Getting past those steps may be the answer to some your other problems. – L. D. James Jan 20 '17 at 3:47
  • Because I have written that it didn't help in this link as a comment . I thought my question was not clearly stated and I posted a new question not to confuse everyone including myself. – voo_doo Jan 20 '17 at 6:55
  • is it the error stated in the first screenshot that you need fixed? – Mark Kirby Jan 25 '17 at 15:51
  • @MarkKirby: I don't know if it is an error or not. It may be a must-go process while starting. I need my computer to run on Ubuntu again. If nothing helps I may reinstall it with USB Flash drive, but one concern: how should I reinstall while I have the above problem? PS: I don't care if I lose my files or software installed on Ubuntu, but I do have to keep my files and software on Windows – voo_doo Jan 27 '17 at 7:09
  • Well it looks like the nouveau open source nvidia driver failed to load, did you ever install the drivers from nvidia? Here is the first thing to try, enter recovery mode wiki.ubuntu.com/RecoveryMode and log in, then run sudo apt-get purge nvidia* then add this PPA sudo add-apt-repository ppa:graphics-drivers/ppa && sudo apt-get update then install this driver sudo apt-get install nvidia-370 then reboot to your normal account. – Mark Kirby Jan 27 '17 at 9:11
2

Based on your lack of concern if you " lose my files or software installed on Ubuntu" and the fact that you can boot Windows via " UEFI with CSM in BIOS" I would reccommend booting from a verified good live media without changing the BIOS from where it successfully boots Windows Once you have successfully booted to the verifed good live media, it would be wise to check the SMART status of your drive to rule out any hardware problem with it that could be impacting your ability to complete installation tasks. Once we have confirmed the following:

1) BIOS mode is set properly to successfully boot Windows

2) Boot into Windows and Turn Off Fast Startup The easiest way to do this is to open a Command prompt as Administrator and issue the command powercfg.exe /h off which will turn off hibernation and fast startup along with it.

2) our live media is uncorrupted

3) our hard drive is in good shape and

4) Verify that the live media is booted via EFI mode matching the mode Windows successfully boots in.

5) We have backed up everything to protect ourselves from unexpected hardware failure and operator error.

Then we can install normally as outlined here.

  • Mr. @ElderGeek I don't think I could understand verified good live media. I have no such experience what to do there. It would be great if I could accomplish the whole process step by step – voo_doo Feb 3 '17 at 1:55
  • It's pretty self explanatory. The idea is to insure that the hash (checksum) of the ISO matches in order to verify that the file has not been corrupted in any way. If there's something you don't understand about that answer Commenting on that answer regarding exactly what is confusing to you there may help others as well as you. – Elder Geek Feb 5 '17 at 14:02
  • Mr. @ElderGeek I insured that the hash of the ISO matches exactly. Should I now boot it with this live media and select try Ubuntu without installation ? – voo_doo Feb 5 '17 at 16:36
  • Yes, and continue on with the steps outlined in my answer. – Elder Geek Feb 5 '17 at 19:52
  • Mr @ElderGeek, I did so ad opened Disks, selected my drive, but in the hamburger menu the SMART Data & Self-Tests is not clickable. – voo_doo Feb 6 '17 at 2:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.