1

When I type sudo curl ifconfig.me it returns my ip, but when I type the same without sudo I get a squid Access Denied error?

Does anyone know why this could be happening?

  • 1
    Have you ever had squid installed on your computer??? – Fabby Jan 19 '17 at 20:00
  • I have, and I have tried to open the conf file just in case it was still there, but cant find it, if it is. curl ifconfig.me was working fine this morning and now I get this error. I must have the file somewhere. How could I find it? – user2829148 Jan 19 '17 at 20:30
  • install squid again and then remove it completely and report back. – Fabby Jan 19 '17 at 21:11
  • @Fabby, it just started working again, strangest thing. But done what you advised. All seems to be fine now, thank you very much for your time, much appreciated. – user2829148 Jan 20 '17 at 9:36
  • Don't go away yet! Answer coming up! – Fabby Jan 20 '17 at 9:48
2

It looks like last time you tried to uninstall squid, it wasn't removed completely, therefore first install squid again:

apt install squid

and then remove and purge it completely:

apt purge squid

Now squid and all of its dependencies are fully removed and the problem will have gone away.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.