0

Context: I attempted an upgrade from 14.04 LTS to 16.04 LTS, and everything went smoothly until just near the end when I got a message that although the upgrade had been installed, some errors had occurred. Doing a bit of digging, it seemed that the 'ubuntu-desktop' package had some unsolvable dependencies. Output of /var/log/dist-upgrade/apt.log:

Log time: 2017-01-09 10:30:59.192116
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) qtdeclarative5-ubuntu-ui-toolkit-plugin [ amd64 ] < none -> 1.3.1918+16.04.20160404-0ubuntu1 > ( libs )
Broken qtdeclarative5-ubuntu-ui-toolkit-plugin:amd64 Depends on qml-module-ubuntu-components [ amd64 ] < none -> 1.3.1918+16.04.20160404-0ubuntu1 > ( libs )
  Considering qml-module-ubuntu-components:amd64 1 as a solution to qtdeclarative5-ubuntu-ui-toolkit-plugin:amd64 0
  Holding Back qtdeclarative5-ubuntu-ui-toolkit-plugin:amd64 rather than change qml-module-ubuntu-components:amd64
Investigating (0) checkbox-converged [ amd64 ] < none -> 1.2.4-0ubuntu1 > ( oldlibs )
Broken checkbox-converged:amd64 Depends on qtdeclarative5-ubuntu-ui-toolkit-plugin [ amd64 ] < none -> 1.3.1918+16.04.20160404-0ubuntu1 > ( libs )
  Considering qtdeclarative5-ubuntu-ui-toolkit-plugin:amd64 0 as a solution to checkbox-converged:amd64 -1
  Holding Back checkbox-converged:amd64 rather than change qtdeclarative5-ubuntu-ui-toolkit-plugin:amd64
Investigating (1) checkbox-gui [ amd64 ] < none -> 1.2.4-0ubuntu1 > ( utils )
Broken checkbox-gui:amd64 Depends on checkbox-converged [ amd64 ] < none -> 1.2.4-0ubuntu1 > ( oldlibs )
  Considering checkbox-converged:amd64 -1 as a solution to checkbox-gui:amd64 0
  Holding Back checkbox-gui:amd64 rather than change checkbox-converged:amd64
Investigating (1) ubuntu-desktop [ amd64 ] < 1.361 > ( metapackages )
Broken ubuntu-desktop:amd64 Depends on checkbox-gui [ amd64 ] < none -> 1.2.4-0ubuntu1 > ( utils )
  Considering checkbox-gui:amd64 0 as a solution to ubuntu-desktop:amd64 0
  Removing ubuntu-desktop:amd64 rather than change checkbox-gui:amd64
Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) ubuntu-desktop [ amd64 ] < 1.361 > ( metapackages )
Broken ubuntu-desktop:amd64 Depends on checkbox-gui [ amd64 ] < none -> 1.2.4-0ubuntu1 > ( utils )
  Considering checkbox-gui:amd64 1 as a solution to ubuntu-desktop:amd64 10000
    Reinst Failed early because of qtdeclarative-abi-5-5-0:amd64
    Reinst Failed because of libubuntugestures5:amd64
    Reinst Failed because of qml-module-ubuntu-components:amd64
    Reinst Failed because of qtdeclarative5-ubuntu-ui-toolkit-plugin:amd64
    Reinst Failed because of checkbox-converged:amd64
Done
ERROR:root:failed to mark 'ubuntu-desktop' for install (E:Unable to correct problems, you have held broken packages.)

However, my system seemed to be doing fine on 16.04 so I ignored this for a little while. But recently, my laptop has been a bit buggy (system fonts not displaying upon re-wake and inability to shutdown properly following this), so I think it is best I try to get 'ubuntu-desktop' installed. I made some of my own attempts using synaptic and aptitude from the command line (instead of apt-get) to see if their smart dependency resolving could help, but to no avail. The output of sudo aptitude install ubuntu-desktop is very similar to the apt.log above [edit: included in full upon request in comments, and I have also included the result upon rejecting the first dependency resolution suggestion]

$ sudo aptitude install ubuntu-desktop
The following NEW packages will be installed:
  checkbox-converged{a} checkbox-gui{a} libandroid-properties1{a} libhardware2{a} libhybris{a} libhybris-common1{a} libmedia1{a} liboxideqt-qmlplugin{a} liboxideqtcore0{ab} liboxideqtquick0{a} 
  libqt5organizer5{ab} libqt5quicktest5{a} libubuntugestures5{ab} libubuntutoolkit5{ab} libunity-webapps0{a} pyotherside{a} python3-aptdaemon.pkcompat{ab} qml-module-io-thp-pyotherside{a} 
  qml-module-qt-labs-folderlistmodel{a} qml-module-qt-labs-settings{a} qml-module-qtgraphicaleffects{a} qml-module-qtquick-layouts{a} qml-module-qttest{a} qml-module-ubuntu-components{ab} 
  qml-module-ubuntu-layouts{ab} qml-module-ubuntu-performancemetrics{a} qml-module-ubuntu-test{ab} qml-module-ubuntu-web{a} qmlscene{a} qtdeclarative5-dev-tools{a} qtdeclarative5-test-plugin{a} 
  qtdeclarative5-ubuntu-ui-toolkit-plugin{a} suru-icon-theme{a} ubuntu-desktop ubuntu-mobile-icons{a} unity-webapps-common{a} unity-webapps-qml{a} unity-webapps-service{a} webapp-container{ab} 
  webbrowser-app{ab} 
0 packages upgraded, 40 newly installed, 0 to remove and 63 not upgraded.
Need to get 43.8 MB/44.2 MB of archives. After unpacking 161 MB will be used.
The following packages have unmet dependencies:
 qml-module-ubuntu-test : Depends: qtbase-abi-5-5-1 which is a virtual package, provided by:
                                    - libqt5core5a, but 5.6.1+dfsg-3ubuntu1~xenialoverlay1~4+fix1 is installed.                                    - libqt5core5a, but 5.6.1+dfsg-3ubuntu1~xenialoverlay1~4+fix1 is installed.
 liboxideqtcore0 : Depends: qtbase-abi-5-5-1 which is a virtual package, provided by:
                             - libqt5core5a, but 5.6.1+dfsg-3ubuntu1~xenialoverlay1~4+fix1 is installed.                             - libqt5core5a, but 5.6.1+dfsg-3ubuntu1~xenialoverlay1~4+fix1 is installed.
 libqt5organizer5 : Depends: qtbase-abi-5-5-1 which is a virtual package, provided by:
                              - libqt5core5a, but 5.6.1+dfsg-3ubuntu1~xenialoverlay1~4+fix1 is installed.                              - libqt5core5a, but 5.6.1+dfsg-3ubuntu1~xenialoverlay1~4+fix1 is installed.
 webapp-container : Depends: qtbase-abi-5-5-1 which is a virtual package, provided by:
                              - libqt5core5a, but 5.6.1+dfsg-3ubuntu1~xenialoverlay1~4+fix1 is installed.                              - libqt5core5a, but 5.6.1+dfsg-3ubuntu1~xenialoverlay1~4+fix1 is installed.
                    Depends: qtdeclarative-abi-5-5-0 which is a virtual package, provided by:
                              - libqt5qml5, but 5.6.1-4ubuntu1~xenialoverlay1~4 is installed.
 qml-module-ubuntu-layouts : Depends: qtdeclarative-abi-5-5-0 which is a virtual package, provided by:
                                       - libqt5qml5, but 5.6.1-4ubuntu1~xenialoverlay1~4 is installed.
 python3-aptdaemon.pkcompat : Depends: python3-aptdaemon (= 1.1.1+bzr982-0ubuntu14) but 1.1.1+bzr982-0ubuntu16~ubuntu16.04~ppa1 is installed.
                              Conflicts: packagekit but 1.1.1-1ubuntu1~ubuntu16.04~ppa1 is installed.
                              Conflicts: packagekit:i386 but it is not going to be installed.
 qml-module-ubuntu-components : Depends: qtbase-abi-5-5-1 which is a virtual package, provided by:
                                          - libqt5core5a, but 5.6.1+dfsg-3ubuntu1~xenialoverlay1~4+fix1 is installed.                                          - libqt5core5a, but 5.6.1+dfsg-3ubuntu1~xenialoverlay1~4+fix1 is installed.
                                Depends: qtdeclarative-abi-5-5-0 which is a virtual package, provided by:
                                          - libqt5qml5, but 5.6.1-4ubuntu1~xenialoverlay1~4 is installed.
 libubuntutoolkit5 : Depends: qtbase-abi-5-5-1 which is a virtual package, provided by:
                               - libqt5core5a, but 5.6.1+dfsg-3ubuntu1~xenialoverlay1~4+fix1 is installed.                               - libqt5core5a, but 5.6.1+dfsg-3ubuntu1~xenialoverlay1~4+fix1 is installed.
 aptdaemon : Breaks: python3-aptdaemon.pkcompat but 1.1.1+bzr982-0ubuntu14 is to be installed.
 webbrowser-app : Depends: qtbase-abi-5-5-1 which is a virtual package, provided by:
                            - libqt5core5a, but 5.6.1+dfsg-3ubuntu1~xenialoverlay1~4+fix1 is installed.                            - libqt5core5a, but 5.6.1+dfsg-3ubuntu1~xenialoverlay1~4+fix1 is installed.
                  Depends: qtdeclarative-abi-5-5-0 which is a virtual package, provided by:
                            - libqt5qml5, but 5.6.1-4ubuntu1~xenialoverlay1~4 is installed.
 libubuntugestures5 : Depends: qtdeclarative-abi-5-5-0 which is a virtual package, provided by:
                                - libqt5qml5, but 5.6.1-4ubuntu1~xenialoverlay1~4 is installed.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
The following actions will resolve these dependencies:

      Keep the following packages at their current version:    
1)      checkbox-converged [Not Installed]                     
2)      checkbox-gui [Not Installed]                           
3)      liboxideqt-qmlplugin [Not Installed]                   
4)      liboxideqtcore0 [Not Installed]                        
5)      liboxideqtquick0 [Not Installed]                       
6)      libqt5organizer5 [Not Installed]                       
7)      libubuntugestures5 [Not Installed]                     
8)      libubuntutoolkit5 [Not Installed]                      
9)      libunity-webapps0 [Not Installed]                      
10)     python3-aptdaemon.pkcompat [Not Installed]             
11)     qml-module-ubuntu-components [Not Installed]           
12)     qml-module-ubuntu-layouts [Not Installed]              
13)     qml-module-ubuntu-test [Not Installed]                 
14)     qml-module-ubuntu-web [Not Installed]                  
15)     qtdeclarative5-ubuntu-ui-toolkit-plugin [Not Installed]
16)     ubuntu-desktop [Not Installed]                         
17)     unity-webapps-common [Not Installed]                   
18)     unity-webapps-qml [Not Installed]                      
19)     unity-webapps-service [Not Installed]                  
20)     webapp-container [Not Installed]                       
21)     webbrowser-app [Not Installed]                         



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

      Install the following packages:                                                                                    
1)      liboxideqtcore0 [1.13.6-0ubuntu1 (xenial)]                                                                       

      Keep the following packages at their current version:                                                              
2)      checkbox-converged [Not Installed]                                                                               
3)      checkbox-gui [Not Installed]                                                                                     
4)      liboxideqt-qmlplugin [Not Installed]                                                                             
5)      liboxideqtquick0 [Not Installed]                                                                                 
6)      libqt5organizer5 [Not Installed]                                                                                 
7)      libubuntugestures5 [Not Installed]                                                                               
8)      libubuntutoolkit5 [Not Installed]                                                                                
9)      libunity-webapps0 [Not Installed]                                                                                
10)     python3-aptdaemon.pkcompat [Not Installed]                                                                       
11)     qml-module-ubuntu-components [Not Installed]                                                                     
12)     qml-module-ubuntu-layouts [Not Installed]                                                                        
13)     qml-module-ubuntu-test [Not Installed]                                                                           
14)     qml-module-ubuntu-web [Not Installed]                                                                            
15)     qtdeclarative5-ubuntu-ui-toolkit-plugin [Not Installed]                                                          
16)     ubuntu-desktop [Not Installed]                                                                                   
17)     unity-webapps-common [Not Installed]                                                                             
18)     unity-webapps-qml [Not Installed]                                                                                
19)     unity-webapps-service [Not Installed]                                                                            
20)     webapp-container [Not Installed]                                                                                 
21)     webbrowser-app [Not Installed]                                                                                   

      Downgrade the following packages:                                                                                  
22)     oxideqt-codecs-extra [1.19.4-0ubuntu0.16.04.1 (now, xenial-security, xenial-updates) -> 1.13.6-0ubuntu1 (xenial)]



Accept this solution? [Y/n/q/?] n

I think this could possibly be related to the launchpad question here https://answers.launchpad.net/ubuntu/+question/433070 which inevitably points out some conflict between qtbase-abi-5-5-1 and qtbase-abi-5-6-1 but I don't have the expertise to conclusively determine that. Given my output, it ceertainly seems like something is up with my Qt libraries (which I don't mess with).

For completeness:

$ lsb_release -crid
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.1 LTS
Release:    16.04
Codename:   xenial
  • 1
    It would help analysis tremendously if you would edit your question and add the output from sudo aptitude install ubuntu-desktop. – Organic Marble Jan 19 '17 at 15:19
  • @OrganicMarble updated as requested – BielsNohr Jan 19 '17 at 15:44
0

In case another Ubuntu internet wanderer stumbles across a similar issue to the above and is wondering if a fresh installation is necessary, then the answer for my case was yes. If you have a suitable backup then this really isn't too onerous. Just make sure you don't pollute your new installation with anything other than 'pure data'. I have started using VMs in which I install third party software in order to 'sandbox' them and isolate them from my host OS which I am attempting to keep as vanilla as possible so that upgrades go smoothly in the future.

See https://ubuntuforums.org/showthread.php?t=2350343 for some more in depth answers to my questions over at UbuntuForums.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.