I have a fresh install of Ubuntu 16.04 on a brand new Dell XPS 13 9365 but the wireless isn't working ( however ethernet is ). I've looked at numerous forum posts for possible fixes and have tried a number of things with no success, including:

  • purging/installing bcmwl-kernel-source
  • sudo service network-manager restart
  • disabling Secure Boot
  • using proprietary drivers and sudo apt-get upgrade

but nothing has worked. here's potentially relevant info:

sudo lshw -C network

  *-network UNCLAIMED     
       description: Network controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:3c:00.0
       version: 78
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:c8a00000-c8a01fff
       description: Ethernet interface
       physical id: 2
       logical name: enxd481d70b47bb
       serial: d4:81:d7:0b:47:bb
       size: 1Gbit/s
       capacity: 1Gbit/s
       capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8152 driverversion=v1.08.2 duplex=full ip= link=yes multicast=yes port=MII speed=1Gbit/s


enxd481d70b47bb Link encap:Ethernet  HWaddr d4:81:d7:0b:47:bb  
          inet addr:  Bcast:  Mask:
          inet6 addr: 2603:300a:50f:4500::82c0/128 Scope:Global
          inet6 addr: fe80::c25f:25b2:a543:41ab/64 Scope:Link
          inet6 addr: 2603:300a:50f:4500:3820:773e:d850:bf44/64 Scope:Global
          inet6 addr: 2603:300a:50f:4500:247e:8cc3:8c88:768c/64 Scope:Global
          RX packets:3297 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3088 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1520006 (1.5 MB)  TX bytes:435638 (435.6 KB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1291 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1291 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:116776 (116.7 KB)  TX bytes:116776 (116.7 KB)


lo        no wireless extensions.

enxd481d70b47bb  no wireless extensions.

cat /etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

lspci -knn | grep Net -A2

3c:00.0 Network controller [0280]: Intel Corporation Device [8086:24fd] (rev 78)
    Subsystem: Intel Corporation Device [8086:8050]
    Kernel modules: wl

cat /etc/NetworkManager/NetworkManager.conf



Your device is not covered until kernel version 4.8. Ubuntu 16.04 uses kernel version 4.4.

You could either install Ubuntu 16.10 or else upgrade your existing install to a 4.8 kernel. In the latter case, connect to the internet by some other way and install the 4.8 kernel

sudo apt update
sudo apt install linux-generic-hwe-16.04-edge

You should also remove the incorrect Broadcom driver:

sudo apt-get purge bcmwl-kernel-source

You also need firmware for this device

wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.161_all.deb
sudo dpkg -i linux-firmware_1.161_all.deb 

Reboot and the wireless device should work.

  • When I try to get that firmware version I get this error HTTP request sent, awaiting response... 404 Not Found Is there an alternative firmware that may also work?
    – Sirdyn
    Mar 15 '21 at 19:41
  • @Sirdyn Quite a bit has changed in 4+ years.Please start your own new question and I'll be happy to help.
    – chili555
    Mar 16 '21 at 1:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.