15

I just got myself a beautiful 27" WQHD display. It is connected to HDMI (no VideoPort) and works great showing 2560x1440 @ 60 Hz.

There is a problem however. When it goes to sleep/I turn the monitor off and then I wake it up/turn it on it doesn't come back. It stays blank eventually displaying "no signal".

The weird thing is when I switch to a different TTY, e.g. Ctrl+Alt+F2 it wakes up, but then going back to Ctrl+Alt+F7 immediately puts it back to sleep and shows "no signal" message. Currently I have to run service lightdm restart in a different TTY in order to wake the monitor up, which is better than reboot but far from ideal. The fact that it can be woken up by switching to a different TTY or restarting X tells me that it is a software related problem.

I am looking for any reasonable solution e.g.

  1. configuration tweak which will force it wake up on keypress
  2. a command that I could give a hot key combination which will wake up the monitor
  3. a driver install/update
  4. anything else that works

As I am running out of ideas I would appreciate any advice, thoughts, guesses. Thanxalot!

P.S. I run xubuntu 16.04 and use Intel® HD Graphics 4600

  • hi. I have the same problem, have you found the reason? On one monitor it takes a few seconds to wake up, but another one does not always wake up. I solved it with just reconnecting the cable. – user87674 Mar 24 '17 at 7:47
  • I have not found the reason so I am getting used to wake it up with "xrandr" script hooked to a key combination. – oᴉɹǝɥɔ Mar 26 '17 at 2:00
  • I'm having the same issue on my LG 27UK650_600; after the screen turns off from inactivity, I have to restart Ubuntu 16.04 to get it to come back on. – Lonnie Best May 14 '18 at 5:43
5

I found a way to wake up the monitor. It is not ideal but much better than restarting X server or rebooting. I created a simple shell script which forces graphics mode to be reset.

#!/bin/bash
xrandr --output HDMI2 --primary --mode 2560x1440

or a simpler one

#!/bin/bash
xrandr --output HDMI2 --auto

Then I assigned a hot key combination to invoke my script. This way the monitor wakes up but only on specific key press vs any key or mouse event.

I will wait for a better answer before accepting my own answer. I am still hopeful that somebody knows a way to fix the actual problem.

UPDATE 2018-01-12 I upgraded kernel from the default LTS version to the latest (https://wiki.ubuntu.com/Kernel/LTSEnablementStack) and the monitor now behaves as it is supposed to. Thanks to @Ellis Whitehead for pointing out it could be a problem in the kernel implementation.

  • FWIW, I began to have issues with my monitor waking up after installing the LTS Enablement Stack. On this positive side, my random computer crashes appear to have been fixed tough. – BillMan Jul 3 '18 at 17:38
-1

I experience the same problem but in my case the HDMI won't wake up in any possible way. Even with hardware interrupts nothing happens. The strange things is that RDP works without any problem.

I found out that 'fsck' shows errors and 'fdisk -l' even more. Also mcelog can be used to detect hardware errors.

  • 3
    Dude, this even remotely doesn't resemble an answer. More like a comment. – oᴉɹǝɥɔ Aug 27 '17 at 3:10
  • 1
    I had to ssh into the machine and run systemctl restart display-managersystemctl restart display-manager. You might be experiencing the problem described here: bugs.freedesktop.org/show_bug.cgi?id=94014 – Ellis Whitehead Oct 27 '17 at 8:02
  • systemctl restart display-manager -- does get the monitor to come back on, but it comes at the expense of also losing your desktop session. – Lonnie Best May 14 '18 at 6:05

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.