4

Starting today, I cannot do any updates on my Ubuntu 16.10 desktop computer. When I try to run commands such as sudo apt-get update it says:

Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libsnmp30:i386 : Depends: libperl5.22:i386 (>= 5.22.1) but it is not installed
E: Unmet dependencies. Try using -f.

When I try to run sudo apt-get install -f, it says:

Get:1 http://archive.ubuntu.com/ubuntu yakkety/main i386 libperl5.22 i386 5.22.2-3 [3,028 kB]
Fetched 3,028 kB in 0s (34.5 MB/s)         
(Reading database ... 336306 files and directories currently installed.)
Preparing to unpack .../libperl5.22_5.22.2-3_i386.deb ...
Unpacking libperl5.22:i386 (5.22.2-3) ...
dpkg: error processing archive /var/cache/apt/archives/libperl5.22_5.22.2-3_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libperl5.22/changelog.Debian.gz', which is different from other instances of package libperl5.22:i386
Errors were encountered while processing:
 /var/cache/apt/archives/libperl5.22_5.22.2-3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Anyone know the trick to fix this? I don't know why I would have a i386 package, since this is a 64-bit installation:

Linux loup 4.8.0-34-generic #36-Ubuntu SMP Wed Dec 21 17:24:18 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
12

Comment #3 from https://bugs.launchpad.net/ubuntu/+source/perl/+bug/1574351 had this workaround which worked perfectly for me:

sudo rm /usr/share/doc/libperl5.22/changelog.Debian.gz
sudo apt-get install -f

Thanks, Reuben Firmin, whoever you are!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.