1

This question already has an answer here:

I am very new to Linux. Ubuntu would freeze so I installed Xubuntu. That would freeze less frequently, but still so. Now, I am on Lubuntu, and it still freezes although least frequently. My system is a Lenovo Thinkpad 11e. Celeron N2940 @ 1.83GHz and 8GB.

The computer freezes in day to day tasks: watching videos, browsing the web, etc. Also, the default word editor was AbiWord. I started a document on AbiWord and saved it. But after my computer froze and I restarted it, it was not able to open that document.

marked as duplicate by David Foerster, Pilot6, Eric Carvalho, TheWanderer, Zanna Jan 21 '17 at 14:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Please, provide more details, like Ubuntu version, Result of free -m, uname -a, etc. Are you using Disk HDD, or SSD?. This seems to be a RAM problem. – GTRONICK Jan 18 '17 at 20:14
  • Lubuntu 16.04. Using SSD. total used free shared buff/cache available Mem: 7866 400 6850 122 616 7081 Swap: 8075 0 8075 Linux name-ThinkPad-11e 4.4.0-59-generic #80-Ubuntu SMP Fri Jan 6 17:47:47 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux – joe Jan 19 '17 at 11:10
  • 3
    This sounds like a hardware fault. Your computer freezes more often when it is working harder. It could be an area of RAM that is bad or even just a temperature rise that causes it. – Robie Basak Jan 19 '17 at 12:48
  • This is definitely the c-state bug, see the second linked duplicate – Zanna Jan 21 '17 at 14:56
1

This is almost certainly due to a bug in the kernel with some Atom-based processors. The workaround is to restrict the machine from going into deeper c-states.

Add intel_idle.max_cstate=1 to the kernel arguments by editing /etc/default/grub and set GRUB_CMDLINE_LINUX_DEFAULT so it looks something like this:

GRUB_CMDLINE_LINUX_DEFAULT="intel_idle.max_cstate=1"

then run

sudo update-grub

More details and the ongoing search for the root cause can be found in the issue at: https://bugzilla.kernel.org/show_bug.cgi?id=109051

  • Okay, I'm not really sure what a c-state is. And I am first time Linux user and would appreciate it if you could please be a little more specific with your directions in applying the workaround. Also, what exactly does that workaround do? I want to understand what exactly is the problem and what will fix it. I am still new and learning Linux so if this is an issue with Lubuntu and my specific CPU then I am open to learning a different distro until this issue is further researched and resolved. – joe Jan 19 '17 at 23:17
  • C-states are states the processor enters to save power. The higher the c-state the more power savings. Your processor is in a family of processors that triggers this bug. It seems that the problem is most likely a combination of a kernel bug and a processor bug. The workaround is to not let the processor go into deeper power saving states and so it will use more power. – Art Gramlich Jan 25 '17 at 13:58
  • If you are familiar with the command line, you can disable the lower power states by editing the file /etc/default/grub and then updating the bootloader. To do that first edit the file: sudo nano /etc/default/grub which will open the file in a text editor. Find the line GRUB_CMDLINE_LINUX_DEFAULT="" and change it to this GRUB_CMDLINE_LINUX_DEFAULT="intel_idle.max_cstate=1" Then save the file using ctrl-x and answering yes to save. then from the command line run sudo update-grub and reboot – Art Gramlich Jan 25 '17 at 13:58
  • Thank you I will do this. But I was wondering, does this affect every Linux distribution? I do not have this problem with Windows 10, and am still trying to wrap my head around what exactly the kernel is. So does every Linux distribution use the same kernel? – joe Jan 25 '17 at 20:54
  • Yes, they all use the "linux" kernel. Distributions that use older versions of the linux kernel don't seem to have this problem, but they also don't fully support the processor. – Art Gramlich Jan 28 '17 at 1:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.