2

I first went through the process in the official docs, running the following in the Driver directory:

sudo make
sudo make install

This seemed to error more than it should, and also didn't show up as a wireless device via ifconfig

It seems to be showing there as a wired connection:

(Note: I do have a phone connected for a USB tethered connection as well)

enp0s29f7u1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet 192.168.42.6  netmask 255.255.255.0  broadcast 192.168.42.255
    inet6 fe80::56a7:45cb:9bc3:1cf9  prefixlen 64  scopeid 0x20<link>
    ether 26:40:47:46:12:94  txqueuelen 1000  (Ethernet)
    RX packets 6113  bytes 4309408 (4.3 MB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 6430  bytes 1073581 (1.0 MB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp1s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
    ether e0:cb:4e:1f:3b:60  txqueuelen 1000  (Ethernet)
    RX packets 0  bytes 0 (0.0 B)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 0  bytes 0 (0.0 B)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
    inet 127.0.0.1  netmask 255.0.0.0
    inet6 ::1  prefixlen 128  scopeid 0x10<host>
    loop  txqueuelen 1  (Local Loopback)
    RX packets 19109  bytes 1196738 (1.1 MB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 19109  bytes 1196738 (1.1 MB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

The USB device does show up from running lsusb, as:

Bus 001 Device 003: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter

This is the output from sudo lshw -class network:

  *-network                 
   description: Ethernet interface
   product: AR8131 Gigabit Ethernet
   vendor: Qualcomm Atheros
   physical id: 0
   bus info: pci@0000:01:00.0
   logical name: enp1s0
   version: c0
   serial: e0:cb:4e:1f:3b:60
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.1-NAPI latency=0 link=no multicast=yes port=twisted pair
   resources: irq:28 memory:feac0000-feafffff ioport:ec00(size=128)

  *-network
   description: Ethernet interface
   physical id: 1
   logical name: enp0s29f7u1
   serial: 26:40:47:46:12:94
   capabilities: ethernet physical
   configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.6 link=yes multicast=yes

I then tried this process as detailed at the page here, as such:

apt-get update
apt-get install linux-headers-$(uname -r)
apt-get update
apt-get install build-essential
apt-get install git
git clone https://github.com/lwfinger/rtl8188eu
cd rtl8188eu
make all
make install
insmod 8188eu.ko

For good measure I also tried installing this, but to no avail: https://launchpad.net/~hanipouspilot/+archive/ubuntu/rtlwifi/+files/rtl8192cu-dkms_0.2_all.deb

I now have 2 wired connections showing, and am confused as to next steps forward ..

1 Answer 1

2

Please try:

cd ~
rm -r rtl8188eu

If it is not there, that's fine, just continue:

git clone https://github.com/lwfinger/rtl8188eu
cd rtl8188eu
make
sudo make install
sudo modprobe 8188eu

It 'makes' perfectly on my 4.8.0-34 kernel; however, if you encounter any errors, please post them.

Please check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/images/netconfig/network-connections-ipv6-ignore.png This example is for ethernet, but you want wireless.

19
  • From 'make clean', the errors in order: make: *** No rule to make target 'clean'. Stop. make: *** No targets. Stop. make: *** No rule to make target 'install'. Stop. modprobe: FATAL: Module 8188eu not found in directory /lib/modules/4.8.0-34-generic
    – Deci
    Jan 19, 2017 at 23:00
  • Please see my edit above.
    – chili555
    Jan 20, 2017 at 16:33
  • I assume you meant to cd into the rtl8188eu folder before running make, and I had to sudo one or two of the others too. It's difficult to comment with big output here, so please see this pastebin
    – Deci
    Jan 21, 2017 at 14:23
  • I certainly did not intend for you to compile this in /usr/src/linux-headers-etc.! Please see my edit above in a few moments. Also, when any step ends in an error, all of the following steps will also fail, so there is no need to continue.
    – chili555
    Jan 21, 2017 at 15:25
  • Yes it seemed a little strange, as believed I cloned into my home before, maybe not then. Good news though as look like we're getting closer :) Some nice healthy output from this make (see here). Now we have 'Enable Wifi' in the system network dropdown! However 'Wi-Fi Networks' in the same place is greyed out .. I looked at dmesg and saw some possible issue (see here).
    – Deci
    Jan 21, 2017 at 21:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .