14

The accepted solutions in other questions, ie:

echo manual > /etc/init/cups.override
echo manual > /etc/init/cups-browsed.override
reboot

Don't work in 16.04. I don't wish to uninstall cups as I'll occasionally need it, but I don't want the service to start automatically on startup.

How can I achieve this in 16.04?

30

Since Ubuntu 16.04 aka Xenial is using systemd as init, you have to use systemctl to control/start/stop services.

In your case the lines as follows should do the job.

systemctl stop cups
systemctl stop cups-browsed
systemctl disable cups
systemctl disable cups-browsed

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.