I'm trying to install Ubuntu 16.04 from a USB drive. I'm using Rufus to create a bootable stick, but everytime I click start, it starts, and then gives the error ISO image extraction failure. What can I do?

  • Rufus has a good reputation. Which version of Windows are you running? Did you check that your iso file is good.? - You can use md5summer in Windows to check it. An alternative, that works to install Ubuntu 16.04.1 LTS (you should use the first point release with .1 in the file name) from all Windows versions including XP is Win32 Disk Imager, wiki.ubuntu.com/Win32DiskImager/iso2usb – sudodus Jan 18 '17 at 12:23
  • I run Windows 10. – jimpix Jan 18 '17 at 13:05
  • Rufus should work for you in Windows 10. Did you check the iso file? – sudodus Jan 18 '17 at 13:08
  • @sudodus I downloaded the ISO from the Ubuntu website but it still doesn't work. What's going on? – jimpix Jan 18 '17 at 13:43
  • It's either a corrupt download or the file gets corrupted when saved (faulty drive) or is somewhere Rufus can't read correctly from or an antivirus: github.com/pbatard/rufus/issues/289 – user589808 Jan 18 '17 at 13:59

What can I do?

  1. Check the MD5 of your ISO which too few people know you can ACTUALLY do using Rufus! Just click on the (✓) button next to SELECT (Rufus 3.0 or later) or the # button at the bottom of the Rufus interface (Rufus 2.18 or earlier) after selecting your ISO. There is no need to use another tool.
  2. Run a bad blocks check in Rufus, to make sure that the issue isn't with your flash drive.
  3. Report that issue in the official issue tracker for Rufus, along with your full log from Rufus, as this is the best place to get help with Rufus issues.
  • What do I do after checking the MD5 of my ISO? – jimpix Jan 18 '17 at 15:01
  • What do I do after checking the MD5 of my ISO Either there's a match (ISO is fine) or there isn't (ISO is corrupt). – user589808 Jan 18 '17 at 15:27
  • Indeed, you need to check that the MD5 reported by Rufus matches the official MD5 of your ISO as provided by Ubuntu here. All Rufus (or any other MD5 generation tool) does is compute the checksum. It's up to you to confirm whether it matches. – Akeo Jan 18 '17 at 16:05
  • @CelticWarrior My MD5 matches, but Rufus fails to create a bootable stick. – jimpix Jan 25 '17 at 8:58

for me the case was that I deleted the rufus_files folder rufus created when it's ran for the very first time. Actually, I keep a different folder for softwares, so i only copied .exe after i did my first iso extraction with rufus and deleted the folder (rufus_files).

so, just reinstall rufus and keep the folder.


  • I only deleted the rufus.ini and it worked fine when I tried again. I had a rufus.ini from a previous version and it was causing the error. – DGaleano Jan 7 at 14:57

Mine was failing because my Front USB ports on my case was causing write failures to the thumb drive. Plugged in the back ports and all was good.


I was trying to create the bootable USB from my office laptop and got in to this issue. I have read many solutions and it didn't work out. From one answer they said it might be due to the anti-virus effect and i tried using my personal laptop and it did work out.


For me in Windows 10, it seems that MS denies rufus access to items in downloads and desktops, so am unable to actually choose/select the Ubuntu image to send to USB stick.


On Windows install the program PowerISO. Then:

  1. Open your ISO file.
  2. Delete autorun.inf.
  3. Save and exit (overwrite).



Just run rufus as administrator and it works on Windows 10. Otherwise it cannot find the iso file or downloads folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.