2

I want to use different wallpaper on each workspace, but the following does not change background wallpapers:

There are problem ....left -right at click on workspaces.(Ubuntu 10.04)...

startwall.sh a file I have created and I called Terminal in sh startwall.sh and I added Startup Application and I have Run to applicatiion.But I want to Play as Automatic Background always on each Workshapes.

           Code:
#!/bin/bash     
ws=$(wmctrl -d | wc -l)
cws=$(wmctrl -d | awk '/*/    {print $1}')   
lws=$(($cws-1))
if [ $lws = -1 ]; then
    lws=$(($ws-1)) 

    gconftool -t string -s /desktop/gnome/background/picture_filename "/root/Desktop/wall/b.jpg"; 
else
    gconftool -t string -s /desktop/gnome/background/picture_filename "/root/Desktop/wall/q.jpg
fi

OR

#!/bin/bash

#  ws=$(wmctrl -d | wc -l)
cws=$(wmctrl -d | awk '/\*/ {print $1}')
if [ $cws = 0 ]; then
    wmctrl -s $cws
    gconftool -t string -s /desktop/gnome/background/picture_filename "/root/Desktop/wall/b.jpg"
else
    gconftool -t string -s /desktop/gnome/background/picture_filename "/root/Desktop/wall/q.jpg"
fi
  • Can you clarify your question please? It's hard to tell what you're asking or what your problem is. – Caesium Dec 13 '11 at 2:35
  • ok..I want to use different wallpaper on other workspaces....but does not change background wallpapers..gconftool-2 -s /apps/compiz/plugins/wallpaper/screen0/options/bg_image -t string "[/root/Desktop/wall/q.jpg,/root/Desktop/wall/b.jpg] " --->ubuntu 10.04 – erkan şentürk Dec 13 '11 at 2:43
  • 1
    Seems very similar to askubuntu.com/questions/4497/… – itnet7 Dec 13 '11 at 3:04
  • Thank You.. But is not the right answer. – erkan şentürk Dec 13 '11 at 3:08
  • @erkanşentürk: there is an edit button below your post, which you can use to revise your question. If you want to add more than a simple comment, it would be easier for everyone else to read if you used that button to add the new information. – James Henstridge Dec 13 '11 at 7:05
0

You can get the Wallpaper plugin for Compiz by installing compiz-fusion-plugins-extra (sudo apt-get install compiz-fusion-plugins-extra). It will show up under the Utility category in CompizConfig Settings Manager. enter image description here

Before you can use it, you'll have to configure Nautilus to not draw the desktop. Run gconf-editor and uncheck the setting /apps/nautilus/preferences/show_desktop. This will make all of your desktop icons disappear, and there is no solution to this drawback at this time.

To configure the Wallpaper plugin, add images to the list of backgrounds. They will be assigned to workspaces in the order they are listed.

CompizConfig

  • 1
    > >Thank YOU + - But is not the right answer.Because I am needed wmctrl control scipt ....for left -right at click on workspaces. – erkan şentürk Dec 13 '11 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.