I installed Ubuntu 16.04 on a laptop solely equipped with NVIDIA M1000M graphics card. During installation I was able to edit the boot options from the GRUB menu (the one with try without installing, install, install as OEM) and add nomodeset to the boot command. If I didn't do this I would get a purple screen rather than the installation process.

Once Ubuntu 16.04 was installed, however, I can't figure out how to add nomodeset or boot into a terminal-only mode so I can install the necessary drivers. These are the things I tried:

  1. hold shift while booting to load GRUB menu, but it never loads.

  2. hold Ctrl+Alt+F[1-6] to go to terminal but didn't work.

  3. hold Esc while booting gets me to the GRUB terminal. how can I boot into a nomodeset or terminal only mode from here to install the right drivers?

For context (not sure if these are relevant): BIOS has UEFI, 2HDs with RAID0.

Thanks!

The easiest way to do this is to boot from the live Ubuntu CD and boot into the interface with nomodset.

Now mount your hardisk by clicking to the left bar that shows the icon of your harddisk, nautilus will open, now close it.

Open the terminal and type:
sudo nautilus

The the Nautilus file manager will open once again.
Into the Nautilus click your harddisk icon (usually is bunch of numbers) to see your folders.

Open these folders:
etc - default

See the flie named grub
Open the file grub with gedit

Now search for the line that says:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

And add the nomodset command to look like this: GRUB_CMDLINE_LINUX_DEFAULT="nomodset quiet splash"

Save and Quit gedit.
Restart and remove Ubuntu CD to boot from your harddisk.

To remove the nomodset command from your grub after you are done removing the proprietary Nvidia drivers open a terminal and:
sudo su
cd //
gedit /etc/default/grub

Is highly recommended to do not use the proprietary drivers since everything works fast and without tearing problems except if you are using Kali Linux with Nvidia cuda which is a different "dark" story.

  • Thanks for your answer! When I boot from the live USB I don't see a screen like askubuntu.com/questions/162075/… Instead it takes me straight to a menu with options Try Ubuntu Install Ubuntu OEM Install Check for Defects If I press c I am able to enter the grub terminal. – Puppy Cyber Jan 19 '17 at 16:38

I disabled UEFI secure boot in BIOS, and this allowed me to boot with into GRUB menu rather than directly or into GRUB terminal.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.