1

I am a Linux and Ubuntu newbie, and converted an old laptop to run Ubuntu (sole OS). The Machine is Sony Vaio SZ VGN-SZ75GN/B, with Intel Core 2 Duo, 3GB RAM, and NVIDIA GEFORCE 8400M GS GPU in a hybrid graphic configuration. Ubuntu is 16.04 LTS 32bit, and chksum verified before installation.

The problems are:

  1. Sometimes at start-up, the screen just shows a black and white pattern and nothing happens

  2. Sometimes it does start up, but as soon as I click the Ubuntu Icon, the screen goes garbled for a while, and resets when i click some other area

  3. I tried the following commands and their results are:

    sudo grep -i switcheroo /boot/config-*
    /boot/config-4.4.0-31-generic:CONFIG_VGA_SWITCHEROO=y
    /boot/config-4.4.0-59-generic:CONFIG_VGA_SWITCHEROO=y
    
    lspci -v |grep VGA
    01:00.0 VGA compatible controller: NVIDIA Corporation G86M [GeForce 8400M GS] (rev a1) (prog-if 00 [VGA controller])
    

Please advise what can I do further to fix these issues. I don't intend to run games or like, so would be ok to use one or the other card.

Much appreciated...

  • Any reason for the 32bit? (Core2Duo is 64bit) – user589808 Jan 17 '17 at 15:44
  • I had a vista 32-bit installation on it as OEM install - used that info and didn't research more before installing. – jappudesi Jan 18 '17 at 2:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.